Video SDK 1.4 not recording sessions

The zoom recordhelper function fails to turn on recording. We have successful sessions started with the react native video sdk using version 1.4

But when we select record as the host we never get recordings in our dashboard of our zoom account.

Hi @samuel.mula30 was this something that recently started occurring on this version? Is this happening on iOS or Android?

Hello. Our team did a bit of account bouncing. We had the videosdk pay as you go and added the cloud recording package. We used the video sdk v1.4, successfully created sessions and the recordings appeared in our dashboard using both android and ios.

We were given a bit of misinformation from zoom account’s when we asked if we needed multiple accounts for simultaneous sessions using the video sdk sessions. So the initial account mentioned above was deleted and we switched to a different account subscription. In the devforum we came to find out that we could use the same account and create simultaneous sessions with the videosdk. After creating a new user account with and going back to our videosdk implementation we used previously, we can again create sessions but now we no longer see any recordings in our dashboard for both android and ios.

All of this happened recently. The account flipping happened around November 2022.

So I dont know if this is an account issue related to our sdk token not linked to the cloud recording package?

Any suggestions for me to help resolve this?

const canStartRecording = await zoom.recordingHelper.canStartRecording(); returns false

The session can be started. But recording cannot.

Hi @samuel.mula30 , to confirm when you made the switch, you were able to make and see the recordings as expected up until very recently?

I would follow up with sales to confirm that the cloud recording add-on plan is active for your current account/video SDK credentials and confirm that the Cloud recording feature enabled on the Web portal.

Yes that is correct. If there is nothing else for me to help diagnose programmatically i will follow up with sales.

Thank you for the quick response.

Hi @samuel.mula30 , please follow up with me and let me know the result of your conversation with sales! I will escalate if there is a programmatic issue our team is unaware of.

Hello Gianni,

I have been in touch with Zoom and it has been very troublesome.  My one colleague connected with zoom by phone while I connected via the chat bot.  

Both seem to be unaware of how the VideoSDK works and trying to get us to create a Pro plan instead of the videoSDK plan we currently have to correct the issue.

The live chat individual directed me back to the Dev Forum and sent links to the WEB video SDK posts. They were not helpful for our issue. I was told a billing sync will be conducted. I am curious if it matters when the Video SDK credentials are created because I believe I created them before the zoom recording package was added. I am tempted to delete the app and create a new app with new sdk credentials.

My colleague on the phone call didnt get any further. We are told we will be contacted by the correct department for our issue.

I will keep you posted on issue. Thanks for the checkin.


Hello Gianni,

The Billing Sync was completed last night. I tried for several hours to get the recording to work but still no luck.

I redownloaded the React Native Version 1.4 and used the example code.
I recopied the mobilertc from Android version 1.4 to my android project folder.
I checked all my android permissions.

Below is my Server Side ZOOM SDK JWT
var zoomToken = (req,res,next) =>{
var zoomBody = req.body;
var zoomID = req.user.userID;
const iat = Math.round((new Date().getTime() - 30000) / 1000)
const exp = iat + 60 * 60 * 2
var zoomHeader = {
“alg”: “HS256”,
“typ”: “JWT”

    var zoomPayload = {
        "app_key": environment.zoom_sdk_key,
        "tpc": zoomBody.session_name,
        "version": 1,
        "role_type": zoomBody.type==="Veterinarian"?1:0,
        "user_identity": zoomID,
        "session_key": zoomBody.session_key,
        "iat": iat,
        "exp": exp,
        "pwd": "12345"
    const sHeader = JSON.stringify(zoomHeader)
    const sPayload = JSON.stringify(zoomPayload)
    const sdkJWT = KJUR.jws.JWS.sign('HS256', sHeader, sPayload, environment.zoom_sdk_secret)
        res.status(200).send({sdkJWT:sdkJWT,... zoomBody});
        res.status(500).send({message:"Unable to create Zoom Session. Please try again."})


Session is generated fine.
But when I am in the session and use the more button to access turn record on the recording never starts.
I never see Recording in the Zoom Dashboard for the Live or Past Sessions

One attempt was the following to add the recording for when the camera is turned on.

const onPressVideo = async () => {
const permissionAndroid = await PermissionsAndroid.check(‘android.permission.CAMERA’);
if(permissionAndroid != PermissionsAndroid.RESULTS.granted){
const reqPer = await PermissionsAndroid.request(‘android.permission.CAMERA’);
if(reqPer != ‘granted’){
return false;
const mySelf = await zoom.session.getMySelf();
const videoOn = await mySelf.videoStatus.isOn();
videoOn ? zoom.videoHelper.stopVideo() : zoom.videoHelper.startVideo();
const canStartRecording = await zoom.recordingHelper.canStartRecording();
console.log(“Can Start Recording”, canStartRecording);



Can Start Recording 0

Another attempt

const onPressRecord = async () =>{
const permissionAndroid = await PermissionsAndroid.check(‘android.permission.INTERNET’);
if(permissionAndroid != PermissionsAndroid.RESULTS.granted){
const reqPer = await PermissionsAndroid.request(‘android.permission.INTERNET’);
if(reqPer != ‘granted’){
return false;

const recordOn = await zoom.recordingHelper.getCloudRecordingStatus();
let recResult = await zoom.recordingHelper.startCloudRecording();
recordOn ? await zoom.recordingHelper.stopCloudRecording():
await zoom.recordingHelper.startCloudRecording();;
//turn video recording on
console.log("Session Name",sessionName);
console.log("Recording Status", recordOn);
console.log("Record On Result", recResult);


Can I chat with you? Can I send my SDK App credentials to you to see if you can get a session to start and record? Do I need to check more permissions? How would I delete the app in Marketplace and get new credentials?

Many thanks

Cloud recording not working on latest VideoSDK - Video SDK / iOS - Zoom Developer Forum

Did you ever find a resolution to this issue?

Hi @samuel.mula30 , I’m sorry to hear how frustrating this has been to try to troubleshoot. I am going to message you for your SDK credentials and the email associated with your Video SDK account to see if there’s anyway Cloud Recording was disabled from your account. This is something that should have been confirmed via Support channels so I’ll make sure to share that feedback.

As for the other developer – I did not hear from them again and was unable to reproduce, but I’m going to follow up there as well!

This topic was automatically closed after 30 days. New replies are no longer allowed.