Web SDK attempting to connect to invalid DNS names

Meeting SDK Type and Version
Web 2.6.0

Starting in the last few days, we’ve noticed a large uptick in the Web SDK attempting to connect to urls with missing DNS records.

From my understanding, the Web SDK makes an API request to retrieve meeting information and receives in the response some regional endpoints used when setting up the meeting. We’ve started seeing errors for the following domains:

  • zoomiad94rwg.iad.zoom.us
  • zoomiad93rwg.iad.zoom.us
  • zoomiad10rwg.iad.zoom.us

dig shows that these domains are missing A records:

$ dig +short zoomiad94rwg.iad.zoom.us A

Testing locally, all the domains the SDK has attempted to use resolve as expected, for example:

$ dig +short zoomnxs151rwg.nx.zoom.us A

Obviously this is causing a pretty negative user experience for our users. Any chance these spurious domains could be fixed or removed from the rotation? Thanks.

We see this (redacted) error in the browser console:

WebSocket connection to 'wss://zoomiad94rwg.iad.zoom.us/wc/api/XXX?...' failed: Error in connection establishment: net::ERR_NAME_NOT_RESOLVED

Hi any update here? This is still occurring and impacting our users.

Still occurring as of a few moments ago. (I’m attempting to make it through the sales labyrinth for “Premier Dev Support” to see if I can talk to someone… until then I’ll keep this thread fresh as this is a pretty impactful production outage).

@ryan has this issue been solved we were facing it until yesterday did you get to reach zoom on this

Happy to report that the last instance of this that we’ve seen was at 2022-09-21 23:47:19Z. We’ll continue monitoring today.


Thank you for reporting this. I am happy to report this to our backend engineers, please let me know if this issue presists on your end.

Thanks for contacting your backend engineers @donte.zoom. It appears that this has grown into an even more serious issue, which @ryan has helpfully flagged in his new forum post.

It appears that even Zoom’s own website is broken, in that if you go to a meeting (e…g, Launch Meeting - Zoom), and click on the bottom “Join from Your Browser”, it doesn’t load.

Since Zoom’s own website is broken, this issue is definitely not due to any 3rd-party developers not fully understanding how to implement the SDK. Could you please ask the backend engineers to fix this problem as soon as possible? We rely extensively on the SDK for our educational technology service, and this is a severe breakage. Thank you!

1 Like

Hi @poshenloh
Are you still experiencing this issue on your end?


Thank you very much for checking in. Everything works now! :slight_smile:


Thanks for confirming this and happy to hear that everything is back to normal now :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.