Web SDK attempting to connect to invalid servers

(This seems eerily similar to my previous issue: Web SDK attempting to connect to invalid DNS names)

Meeting SDK Type and Version
Web 2.6.0

Starting today (2022-10-02) around 18:49Z, we started seeing a high frequency of ERR_ADDRESS_UNREACHABLE errors from the Web SDK failing to connect to the client websocket.

Unlike my previous issue, this doesn’t not appear to be a DNS issues (the domains have a valid A record) but instead an issue with the server on the domain. The following domains have caused the error so far:

  • zoomiad206247100129rwg.iad.zoom.us
  • zoomiad206247100130rwg.iad.zoom.us
  • zoomiad206247100131rwg.iad.zoom.us
  • zoomiad206247100132rwg.iad.zoom.us
  • zoomiad206247100133rwg.iad.zoom.us
  • zoomiad206247100134rwg.iad.zoom.us
  • zoomiad206247100135rwg.iad.zoom.us
  • zoomiad206247100136rwg.iad.zoom.us
  • zoomiad206247100137rwg.iad.zoom.us
  • zoomiad206247100138rwg.iad.zoom.us
  • zoomiad206247100139rwg.iad.zoom.us
  • zoomiad206247100140rwg.iad.zoom.us
  • zoomiad206247100141rwg.iad.zoom.us
  • zoomiad206247100142rwg.iad.zoom.us
  • zoomiad206247100143rwg.iad.zoom.us

As best as I can tell, there is just not server responding to requests on these domains.

Testing one of the domains my client attempts to use locally:

$ wscat -c wss://zoomsjc1441959728rwg.sjc.zoom.us/wc/api

connected (press CTRL+C to quit)
< {"evt":0,"seq":0,"body":{"test":"welcome to zoom!"}}
< {"evt":0,"seq":1,"body":{"status":"READY"}}
< {"evt":0,"seq":0,"body":{"test":"invalid parameters!"}}
disconnected (code: 1006)

vs one of these problem domains:

$ wscat -c wss://zoomiad206247100129rwg.iad.zoom.us/wc/api

error: connect ECONNREFUSED

We see this (redacted) error in the browser console:

WebSocket connection to 'wss://zoomiad206247100129rwg.iad.zoom.us/wc/api/XXX?...' failed: Error in connection establishment: net::ERR_ADDRESS_UNREACHABLE
1 Like

I’m also having this issue. It appears that there is an issue even on Zoom’s own “Join from Your Browser”. For example, if you go to this URL (Launch Meeting - Zoom) in a Google Chrome incognito window, and click on the “Join from Your Browser”, you get a popup with the error “Joining Meeting Timeout or Browser restriction”. In our Zoom account, we have no Browser restriction. Actually, we’ve been using Join from Browser every day for almost a year.

The breakage in the Zoom Web SDK is severely impacting our workflow. We operate live video education, and our app is built around this SDK. Could you please help to fix this problem as soon as possible? Thank you!

I tried this both with Zoom’s own website (“Join from Your Browser”), as well as the new v2.8.0 Meeting SDK Web. Both encountered the same issues that Ryan raised.

1 Like

@ryan @poshenloh - Thank you for reporting this. Our teams is currently looking into this issue.

1 Like

@ryan @poshenloh - Our team has resolved the issue as reflected in the following status post.

1 Like

@brendan.zoom we were still facing this issue , the post you shared suggests that this issue is already solved but we are facing this issue still

@ryan is this still happening on your side

Error message : failed: Error in connection establishment: net::ERR_ADDRESS_UNREACHABLE

I can confirm that the last instance of ERR_ADDRESS_UNREACHABLE we observed was at 2022-10-03 05:40:36Z, so it does appear as if this issue has been resolved.

Thank you for quickly responding to this report @brendan.zoom. This is the second highly impactful “networking” issue in the IAD region in the past two weeks, is there some on-going maintenance in this datacenter that’s causing this instability?

I’m assuming the timestamp on the status page issue was a typo.

@srinjoy my issue certainly appeared to be region specific, are you seeing these issues still in the IAD region?

Thank you! Our system works again! I really appreciate your quick response!


Hi @srinjoy
Just checking in with you, are you still experiencing this issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.