Web SDK (JWT), Computer Audio, Video, Share Screen not working on local host (unsecured) chrome browser

Using the zoom init, join function with the proper API keys

  1. the computer audio button is disabled on initialization
  2. browser will not identify the video camera
  3. share screen does not work.

Version 1.72

Code
ZoomMtg.setZoomJSLib(‘https://source.zoom.us/1.7.2/lib’, ‘/av’);
ZoomMtg.preLoadWasm();
ZoomMtg.prepareJssdk();

  const meetConfig = {
apiKey: "{{zoom_api_key}}",
meetingNumber: "{{zoom_add_existing_meeting_number}}",
leaveUrl: "{{request.build_absolute_uri}}",
userName:"{{user.user_fullname}}",

userEmail:"{{user.user.email}}",
apiSecret:"{{apiSecret}}",
passWord: “{{zoom_add_existing_password}}”,
role: 0
};

var signature = ZoomMtg.generateSignature({
meetingNumber: meetConfig.meetingNumber,
apiKey: meetConfig.apiKey,
apiSecret: meetConfig.apiSecret,
role: meetConfig.role,
success: function(res){
console.log(res.result);
}
});

document.addEventListener(“DOMContentLoaded”, function(event) {
ZoomMtg.init({
leaveUrl: meetConfig.leaveUrl,
isSupportAV: true,
screenShare: true, // default, and it also require account’s sharing setting enabled.
disableJoinAudio: false, //optional

  success: function() {
    ZoomMtg.join({
      signature: signature,
      apiKey: meetConfig.apiKey,
      meetingNumber: meetConfig.meetingNumber,
      userName: meetConfig.userName,
      userEmail: meetConfig.userEmail,
      passWord: meetConfig.passWord,
      success: function(res){
                 $('#nav-tool').hide();
                 console.log('join meeting success');
   
             },
             error: function(res) {
                 console.log(res);
             }
      // Email required for Webinars
      // userEmail: meetConfig.userEmail,
      // password optional; set by Host
      // password: meetConfig.password
    });

  },
  error: function(res) {
    console.log(res);
  }
});

});

Screenshots
Disabled computer audio button (below)


share screen error(below)

Hey @ogbonnaya83512,

Please see the following Web SDK update:

We are working to get the Zoom Web Client and Zoom Web SDK back online. Please keep up with our status page for detailed updates: status.zoom.us


The best workaround is to use the Zoom Desktop / Mobile app.

Just include the Zoom meeting join url (https://zoom.us/j/meetingID) on your site rather than showing the websdk / iframe. Clicking on the join url will open the Zoom meeting in the Zoom app.

Apologies for the inconvenience,
Tommy

@tommy I updated to 1.7.4, loving the UI updates by the way, however, I am still having the same issues noted above.

1 Like

Hey @ogbonnaya83512,

Can you try serving over https? You can do this with localhost using the free ngrok.io tool.

Thanks,
Tommy

1 Like

Thank you very much, your suggestion worked! Once I ran my site from the https url, provided my ngrok.io, I had full functionality of the zoom interface. Might I suggest, adding your solution to the documentation, I am sure it would help other developers as well.

1 Like

Hey @ogbonnaya83512m

Happy to hear it worked! :slight_smile:

Yes, we will add this to our docs! CC @Michael_Purnell

Thanks,
Tommy