Web SDK sample code -GETs issues by join function have empty response

I am using the CDN code locally on a desktop for Web Meeting SDK 2.7.0 (and tried 2.6.0 with no difference in result) to attempt to access a meeting opened from my phone. Open the attempt to join, the “Joining Meeting” spinner spins continuously, the the Network shows 3 promises at a time failing continuously, and the console shows a NET::err_empty_response for the GETs.
The only change to the code is pasting of the SDK key and secret key. I’ve tried to access meetings with passcode required and with waiting room option alone.
The signature is the one generated in the index.js code.
Since there is no exact example of setting up a meeting and the sample code to ensure success, it is unclear whether something is not setup correctly with the meeting or in the code.

Browser Console Error
GET https://rwcnv.nv.zoom.us/wc/ping/4390449920?ts=1662821021552&auth=1Hpt … &dmz=1 net::ERR_EMPTY_RESPONSE

xhr requests in the Network viewer show failed. Initiator is zoom-meeting (3 of these at a time)

Which Web Meeting SDK version?
2.7.0 (same problem when tried 2.6.0)

Meeting SDK Code Snippets
function beginJoin(signature) {
debug: true,
isSupportAV: true,
leaveUrl: meetingConfig.leaveUrl,
webEndpoint: meetingConfig.webEndpoint,
disableCORP: !window.crossOriginIsolated, // default true
//disablePreview: false, // default false
externalLinkPage: ‘file://d:/xampp/zoom-sdk-web-2.7.0/CDN/externalLinkPage.html’,
success: function () {
console.log(“signature”, signature);
meetingNumber: meetingConfig.meetingNumber,
userName: meetingConfig.userName,
signature: signature,
sdkKey: meetingConfig.sdkKey,
userEmail: meetingConfig.userEmail,
passWord: meetingConfig.passWord,
success: function (res) {
console.log(“join meeting success”);
console.log(“get attendeelist”);
success: function (res) {
console.log(“success getCurrentUser”, res.result.currentUser);
error: function (res) {
error: function (res) {

To Reproduce(If applicable)
It seems everyone should be having this problem who use the sample code. So, I’m likely missing a detail. But, setting up a meeting with passcode (and tried with only waiting room), join as hose on my cell phone through normal zoom app. Then attempt to access with the index.html of the sample code. The entire SDK folder is copied as is with only changes to the keys as needed.

role: 0
passWord is the passCode
signature generated by the index.js call:
var signature = ZoomMtg.generateSDKSignature({
meetingNumber: meetingConfig.mn,
sdkKey: SDK_KEY,
sdkSecret: SDK_SECRET,
role: meetingConfig.role,
success: function (res) {
meetingConfig.signature = res.result;
meetingConfig.sdkKey = SDK_KEY;
var joinUrl = “file://d:/xampp/zoom-sdk-web-2.7.0/CDN/meeting.html?” + testTool.serialize(meetingConfig);
window.open(joinUrl, “_blank”);

They wouldn’t post here.

Troubleshooting Routes
Using the sample for 2.7.0 and 2.6.0. Even put on a website rather on local machine and would not work there.

Device (please complete the following information):

  • Dell G7 17
  • OS: Windows 10
  • Browser: Chrome
  • Browser Version: 105.0.5195.102 (Official Build) (64-bit)
  • Using a VPN, but also tried with it turned off.
type or paste code here

i have no problems with the zoom example (client view, CDN)

just tested with version 2.7.0

5 lines changed


20: var SDK_KEY = ...
26: var SDK_SECRET = ...
112: var joinUrl = "meeting.html?" + testTool.serialize(meetingConfig);


31: leaveUrl: 'index.html',
63: externalLinkPage: 'externalLinkPage.html',

→ the meeting starts without problems (localhost)

to test again, create a new simple meeting with settings

  • Registration NOT required
  • a simple Passcode
  • no waiting room
  • Options: Allow participants to join anytime

enter meeting with “role = 0” (as attendee)

if it not works - upload screenshots of the browser error console (F12 → Console)

Jurgen, thanks for reply. I have used the meeting settings your provided. I was unable to load screen shots previously, but I typed in the results. I tried again, but I get message that you can’t embed media items in a post.
The following is what is in the console and network:
GET https://rwcnv.nv.zoom.us/wc/ping/4390449920?ts=1662821021552&auth=1Hpt … &dmz=1 net::ERR_EMPTY_RESPONSE

xhr requests in the Network viewer show failed. Initiator is zoom-meeting (3 of these at a time)

perhaps a problem of your your browser or the network enviroment

test with Zoom Web Client: copy the Invite Link of your meeting and replace /j/ with /wc/join/

can you join the meeting with this link in your browser ?

Jurgen, Using the link as you suggested gets past the Joining Meeting spinner, but the control buttons are darkened, the rest of the window is black and prior to getting the ERR_EMPTY_RESPONSE errors, there is an uncaught promise error of LOAD_ERROR. Eventually a Joining Meeting Timeout or Browser restriction alert comes up.

if the official Zoom Web Client on zoom.us does not work on your computer, you can temporarily cancel the test of the SDK

and why you cannot upload images? strange

first your network has to fixed, perhapt your firewall is blocking parts of zoom.us

Update: do you access the internet via a company network?

ok. the zoom app works with the meeting. I was on a different network over the weekend with same results. So, it doesn’t seem to be a network problem. To test the browser issue, I tried with Firefox instead of Chrome and got same net effect, but with the following errors (which maybe tells you something?):

Cookie “zm_aid” has been rejected because it is already expired.

Cookie “zm_haid” has been rejected because it is already expired.

Cookie “zm_tmaid” has been rejected because it is already expired.

Cookie “zm_htmaid” has been rejected because it is already expired.

the link provided with these is: info

I turned off nearly all security features in Firefox and turned off VPN and same result.
I see additional (was there before) warnings about: Some cookies are misusing the recommended “SameSite“ attribute

one specific example: Cookie “zm_aid” does not have a proper “SameSite” attribute value. Soon, cookies without the “SameSite” attribute or with an invalid value will be treated as “Lax”. This means that the cookie will no longer be sent in third-party contexts. If your application depends on this cookie being available in such contexts, please add the “SameSite=None“ attribute to it. To know more about the “SameSite“ attribute, read SameSite cookies - HTTP | MDN

I don’t set these cookies. Seems to be something in Zoom library

At this point is seems that on my machine, zoom will not work from any of my browsers (Chrome, Firefox, Edge), so I’m going through what could be going on to not allow zoom to work. This would obviously also keep the SDK from working. If anything rings a bell above with respect to cookies, let me know.

I cannot find a solution to this problem. I tried on a Windows 11 machine and didn’t work there either. So, this is not a computer thing, not a security thing, not a browser thing, so the only thing left is a meeting setup thing. The regular app works. But browsers on any machine and any network with Windows 10 or Windows 11 don’t work.

I assume that the configuration of the VPN is the cause of the problem.

While I had turned off the VPN previously, there was also a virus protection feature that I had not turned off. Turning it off allowed access to the web interface. The SDK works now. The same VPN was setup on the other computer and was the common denominator.

Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.