Web SDK version 1.4.2 is now live

#1

Hello Dev Community,

We’re excited to announce the our Web SDK version 1.4.2 is now live. This release comes with cool new features such as Screen Share and In Meeting Chat.
For a complete list of features see our change log[0]. You can get started with our Web SDK right away using our our sample app[1].

1 - https://marketplace.zoom.us/docs/guides/about-marketplace/recent-updates/web-sdk
2 - https://github.com/zoom/sample-app-web

#2

Hello Michael,

I’m experiencing issues with the latest Web SDK. I’m not sure if that’s related to the update or not since I’m new to Zoom SDK.

I’ve built your sample-app-web and pasted in my API KEY and API SECRET. I’ve created a meeting, and connected to it through the real Zoom app.

Then I pasted in the Meeting Room Id into the sample app and it fails to work. The response I get:
/**/localJsonpCallback({"status":false,"errorCode":200,"errorMessage":"The account don't enable API.","result":null});
I also couldn’t figure out the option in the panel which can ‘enable API’.

I’ve also tried various different approaches but nothing worked.

The only answer to this problem I could find is this one:


Where you wrote that

We recommend to use our V2 API as v1 API is no longer supported by us.
However, I don’t see how I can do that using your zoomus-jssdk.

This is an urgent issue for me. Any assistance will be appreciated!

Best regards,
Jerzy Wozniak

#3

Hi @jerzy

Can you make sure that your account is either a Pro account or a Free trial? If you need a 30 day Free trial, you can submit a support ticket here[1].

1- https://support.zoom.us/hc/en-us/requests/new

Let us know if that helps!

Thanks

#4

Hello again

It turned out to be something else. The OAuth app was not enough to use the Zoom API. We had to create a separate JWT app.

Thanks for your help!

1 Like
#5

@jerzy No problem, happy to help out. Let us know if you need anything else!

Thanks