Webhook event naming


Recently, there was an update to the APIs that add new features and enhancements including the new webhook events. My question is about that naming convention. Previously, webhook events only have a few events and I used a couple of them so far, i.e “recording_completed”, “meeting_ended”. Now, they have been separated into each namespace. I wonder if I need to modify my current settings for the webhook to reflect these new changes or can I still keep using the old one? I believe I still getting the webhook trigger without changing anything to the new stuff, maybe due to some backward compatibility on Zoom backend.

Also, another question is that will there be any changes to the naming convention on all the stuff that will require me to update a lot of stuff later?


Hi @Thai_Nguyen,

It’s best to follow the new changes to the naming convention that we made to make sure that your app receives the notification.

Ok so I ran to an issue when tried to update to the latest events.

I used the same body for the API /webhooks/{webhookId}

  "url": "http://webhookurl.com",
  "events": ["meeting.ended","recording.completed", "recording.stopped"],
  "auth_user": "user",
  "auth_password": "password"

The result is Validation Failed

    "code": 300,
    "message": "Validation Failed.",
    "errors": [
            "field": "events",
            "message": "Invalid scope:[meeting.ended, recording.completed, recording.stopped]"

When I checked the API references for the Webhook, it’s still list the old events. But the recent change page indicated the new event names has been updated.