Meeting.participant_joined hooks not received

For some reason I stopped receivng meeting.participant_joined webhooks. I am receiving meeting.created + meeting.started. This happens sometimes, and I’m still not sure exactly when is participant_joined exactly not being sent…

Hey @alon,

We are aware of some webhook performance degrading due to the same cause of Data Dashboard Delay, as posted at https://status.zoom.us/. Our engineering team has been actively working on the resolution. Please continue to monitor the status at https://status.zoom.us/.

Thanks,
Tommy

@tommy should we be following this incident in relation to webhook delays? https://status.zoom.us/incidents/fx8rk784gdrx

Hey @jimig,

Yes. We are also making some improvements this weekend to help with the webhook issues.

Thanks,
Tommy

Hello @tommy ,

I have the same issue. I can receive meeting.created and meeting.started events, but doesn’t receive any meeting.participant_joined updates.

Looking forward for the fix. Thanks for what you are doing!

Hey @kozzztya, thanks for posting and using Zoom!

To confirm, you have the meeting.participant_joined webhook event selected in your webhook/event subscriptions section of your app?

Thanks,
Tommy

Hey @tommy,
I’m still experiencing this. This doesn’t seem like just retry mechanism webhook which was removed, but rather hooks possibly go unreported at all.
I’m still seeing many meetings in which participant_joined is not reported

@tommy do you have a way to inspect the reported webhooks for a meeting? e.g: 717396498 ? never got any participant_joined and few others

Hey @alon,

I will look into this. They might be delayed some. Have you gotten the respective webhook since?

Thanks,
Tommy

Yes, I’ve started receiving these events.

1 Like

Happy to hear you are receiving them now! :slight_smile:

-Tommy

didn’t get participant_joined for these.
Her’s another meeting id which I did not receive participant_joined hooks but did get meeting.created + started + ended +deleted - 279571999

it seems like the actual problem is this Webhook with id object.id=null