Webinar subscription error in API

Hello Support Team,

We have integrated Zoom with our LMS and it was working last last one year. Here we can create webinar in Zoom using API through our LMS.

But past few days we are getting error on creation of webinar

HTTP Status Code: 400 Bad Request
Error Code: 200 Subscription plan for webinar is missing. Enable webinar for this user once the subscription plan is added:{userId}.

For this error we checked our subscription plan and found it is in active status,

Could you please help me to resolve this on priority.

Awaiting for your reply.

Please update on this,

Hi @shrihari.kale, I do see that your Webinar plan has available hosts licenses. Is the host user you are attempting to create a webinar have a Webinar plan assigned to them?

yes, webinar plan is associated with this account.

please update on this.

Please update on this.

Hey @shrihari.kale,

Please send this with the full error message including the userId to developersupport@zoom.us.

Thanks,
Tommy

Running into a similar problem – we’ve got an JWT authorized App running, which makes Zoom API calls to list webinars.

The “owner” account (under which the App JWT is authorized) does not have Webinar plan – it does not host Webinars. However, another user in the account does Host Webinars.

The App cannot list all webinars; it gets: “400: Bad Zoom response: Zoom API https://api.zoom.us/v2/users/GTC9NTmwSpSn_rsP5O2I0w/webinars?user_id=GTC9NTmwSpSn_rsP5O2I0w&page_number=1 error message: Webinar plan is missing. You must subscribe to the webinar plan and enable webinar for this user: GTC9NTmwSpSn_rsP5O2I0w in order to perform this action.”

Strangely, it can create Webinars, with the Webinar-enabled user as the Host (as it should; the host has a Webinar license)! It just cannot list them…

Update on this; actually, the API works fine; I needed to iterate through all my various users, ignoring the API failure on those without Webinar plans. Just noting that here, for others who run into similar problems.

Thanks!

1 Like

Hey @pjkundert,

Thanks for sharing your solution! :slight_smile:

-Tommy