[WebSDK 1.9.0] Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again

Using API’s we have created a meeting no: [REDACTED]
But when you try to join this meeting via WebSDK we get an error saying

Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again.

We pass user role as 1, use WebSDK 1.9.0
As you can see we do not have any error in console

I can send you steps how to reproduce the issue via email, as you will need to have access to our app. Would not like to share this on an open forum
thank you

Hey @james.petras,

Thank you for reaching out to the Zoom Developer Forum. Just to clarify, do you see this issue when testing with the Sample Web App? Please send an email to developersupport@zoom.us with a link to this thread.

In that email, please include the steps to reproduce the issue as well as the signature that you’re using when you see this issue.

Thanks,
Max

Hi.
I have had similar problems when connecting from the web. Sometimes it works and sometimes it doesn’t.
Set up meetings with a PRO account and sometimes with a password and sometimes without.

Hi @OmarSaaP,

Thank you for using the Developer Forum. Please provide a screenshot of the issue as well as the steps to reproduce it and we’ll look into this further.

Best,
Donte

A the end we discovered what was causing the issue

If we create a meeting (using APIs) and set a host to a zoom licenced user who has
Enable Personal Meeting ID switched on integration would not work. I think there is a clash between a meeting created via zoom interface and API as if the same user creates a new meeting via Zoom website that meeting is going to have pre defined ID, every time - the id doesn’t change, but if we do that via API every single time ID is going to be different

As soon as we set Enable Personal Meeting ID switched off and created a new meeting it worked

Hope this will help to others

Hey @james.petras,

I’m glad to hear that you resolved your issues! Thank you for sharing what worked for you. Please don’t hesitate to reach out if you encounter any further issues or questions.

Thanks,
Max