Where do you set permission for recording:read:master scope?

We have created a Server-to-Server OAuth app and are trying to list all the recordings from all users.

When calling {{baseUrl}}/accounts/:accountId/recordings we get an error message:

“code”: 4700,
“message”: “Invalid access token, does not contain scopes: [recording:read:master, recording:master, recording:write:master].”

We have /recording:read:admin scope and calling {{baseUrl}}/users/:userId/recordings works great for a specific user.

Our admin is not sure where to set the permission for the three master scopes that are needed.

We only have one account for our company so not sure if these master APIs will work in our environment.

Thank you in advance!

Hi @vlad_kolbas
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
Could you confirm if your account has a Master Account plan?
The Master account endpoints can only be accessed if you have a Master account enabled

Hi Elisa, thanks getting back to me!

I asked our admins and waiting for their response. I would hazard a guess that we don’t have a Master Account plan. Our account number is 678649.

Would you be able to help on following issue as well (which is more pressing) https://devforum.zoom.us/t/error-trying-to-download-phone-recordings/92395 ?

Thanks again!

Got a response that we have a Zoom One Enterprise subscription.

So I assume that our admins will not be able to grant me any master level scopes. Which makes sense. I’ll just have to work around it.

Thanks for confirming that information @vlad_kolbas
So that means you wont be able to access any of the master account endpoints