Window filtering during monitor screen share (followup)

Followup from this thread:

At some point, this was ‘fixed’. I have since upgraded to the latest SDK (v5.10.3.6470) but the behaviour has now switched.

Before, it was not possible to hide our client windows. Now, the SDK seems to hide the windows by default, but it is not possible to show the windows.

The SDK API returns the same error as before, just flipped. Passing ‘NO’ works, but passing ‘YES’ returns the WrongUsage error.

This is a preferable scenario for us, since we can still do application share of our own window if necessary, but it would still be nice to have the option to change this.

Which macOS Meeting SDK version?
MacOS 12.3.1

See linked thread for context

Hi @KieranAC,

Since you are unable to enable this setting, it seems likely that this setting is not available for the current meeting. Can you please confirm what you are seeing when you call isSupportShowZoomWindowWhenShare?


Yes you’re right, this returns false

[[[[ZoomSDK sharedSDK] getSettingService] getShareScreenSetting] isSupportShowZoomWindowWhenShare]

I did confirm that this setting is set for my Zoom account

and the setting still returns false. Is there anything else that can influence that setting?

We also checked an account level setting and turned that on as well. Same result as previous.

Hi @KieranAC,

This setting can be applied at the account, user, or group level. Are you sure that this is being applied to the account hosting the meeting and not your developer account? Settings applied to your developer account do not propagate to meetings started through the SDK. One way you can verify this is by starting a meeting through the Zoom client and checking if the setting is available through the settings UI.


Hey @jon.lieblich

We created a new meeting, made sure the setting was applied to both the user (the host of the meeting) and account level, and joined the meeting from the Zoom client and our own app. (With the same account)

The share screen setting is available in the Zoom app, but not our custom app.

In Zoom, this setting hides the Zoom windows in share content (visible in our app)

this setting shows the Zoom windows

there are other settings available:

In our custom client, all of our app windows are permanently hidden regardless as the setting is not settable.

I feel like we’re missing something here, but not sure what it could be. Would logs help?

Hi @KieranAC,

Since you are seeing different results between the Zoom client and the SDK under identical circumstances, I think you’re thinking in the correct direction with getting the SDK logs so we can investigate exactly what is going on.