Windows SDK Demo FAIL in VS2019 (& 17)

Carson,

Thanks for the reply. From the GitHub changelog, I was able to generate a jwt token from the sdk key and secret, but I still get the “auth sdk failed” error panel. I’m not sure if I’m formatting the timestamps and “tokenExp” correctly. Are “exp” and “tokenExp” the same? Is there a specific format? I would guess ISO 8601 for the timestamps, but I still don’t know that “tokenExp” should be in that case.

Thanks,
Nick

@Carson_Chen, thanks again for the help so far. I am generating jwt tokens from the sdk key/secret, but I still get errors. Now, the error panel that shows is seen below:
image
I’ve looked through the documentation, and I can’t find error code 10124. Any ideas on this one?

Hi @nick_ortega,

Thanks for the reply. The error code 10124 means “Unable to verify the token”. Could you provide an example of the payload of your JWT token?

Thanks!

Carson, thanks so much for helping me with this. On another thread, I discovered the problem with my payload. Somewhere along the line, I switched “appKey” to just “key”. I now have it working.

I am still getting the 10124 error. my payload is
Hi @Carson_Chen, @nick_ortega
{
“key”: “--------------------hidden-----------------------”,
“iat”: 1595755181560,
“exp”: 1595757009404,
“tokenExp”: 1595757009404
}

@Carson_Chen I found the solution in some other post. Its working now-

Hi @anuragnagarkota,

Thanks for the reply and glad to hear that the problem has been resolved.

Thanks!

Hi,

I’d like to ask for help here as well. I’m trying to run the SDK demo on my own laptop and I’ve got it running without issue. But when I try to add the JWT token I generated, it returns an error saying “auth sdk failed”

This is the payload I’m using:

Header
{
“alg”: “HS256”,
“typ”: “JWT”
}

Payload
{
“appKey”: “…”,
“iat”: 1516239022,
“exp”: 1516239022,
“tokenExp”: 1516239022
}

Verify Signature
HMACSHA256(
base64UrlEncode(header) + “.” +
base64UrlEncode(payload),

… …

)

Could someone help me find out how to make this work?

Thanks!

Hi @danielle.ureta,

Thanks for the reply. Based on your JWT payload, it seems like the iat, exp, and tokenExp are the same; The iat is the token issue time, and the exp will be the token expiration time so it needs to be larger than iat, and the tokenExp should be a timestamp that is at least 30 minutes from the iat. You may find more info here: https://github.com/zoom/zoom-sdk-windows/blob/master/CHANGELOG.md#new-sdk-initialization-method-using-jwt-token

Please have a try. Thanks!

Hello,

I’m using the advised iat, exp and tokenExp times but keep getting error 10124. I should note that I’m manually setting these times at jwt. io .
Is there a way to add this to the node js api ?

Thanks in advance

Hi @username234234234,

Thanks for the reply. Are you using SDK key/secret to generate the JWT token? Could you provide another sample of the JWT payload? In the last sample of the JWT payload, the iat, exp and tokenExp are the same, which causing the error.

Thanks!

Hi @Carson_Chen,

Having a similar error. I get error code 10124 when I generate my jwt from jwt.io.
Here is my header, payload, and verify signature:
{
“alg”: “HS256”,
“typ”: “JWT”
}

{
“appKey”: “”,
“iat”: 1597693709,
“exp”: 1598693709,
“tokenExp”: 1597793709
}

HMACSHA256(
base64UrlEncode(header) + “.” +
base64UrlEncode(payload),

)

the appKey I fill with my SDK key from my SDK credentials on the zoom marketplace. The SDK Secret I have pasted in with and without quotes. iat < tokenExp < exp. I have my domain still set to https://zoom.us

Any advice? Thanks in advance!

Hi @benv28,

Thanks for using Zoom SDK. Please try to limit the exp to be less than 2 days away from iat. Please have a try. Thanks!

Hey am also getting 10124 error code
{
“alg”: “HS256”,
“typ”: “JWT”

}
{
“appKey”: “keyyyyyyy”,
“iat”: 1597991611000,
“exp”: 1598024011000,
“tokenExp”: 1598027611000

}
HMACSHA256(
base64UrlEncode(header) + “.” +
base64UrlEncode(payload),

)

what can be done to resolve

Hi @pavanschoovideos,

Thanks for the reply.

The unit of the timestamp should be in seconds, please try to convert the timestamp.

Hope this helps. Thanks!

{
“appKey”: “sdk key”,
“iat”: 1598076000,
“exp”: 1598162400,
“tokenExp”: 1598169600

}

getting same error.
will this be the error of time stamp what kind of timestamp should i use can you give a date format for generating timestamp

i have resolved the error it was due to the sdk that i was using when i changed the sdk it works

I too, like everyone else here, am having problems getting the JWT to work in the sample app.

{
“key”: “my app key here”,
“iat”: 1598404372,
“exp”: 1598490772,
“tokenExp”: 1598490773
}

just give the dreaded 10124 return. Authenticating using my app key and secret works fine. I have tried setting “tokenExp” to values before, equal to and after “exp”, to no effect.

JWT.IO reports the “iat” and “exp” values as correct dates.

I’m really struggling to make this work. Failing at the first hurdle in the sample app makes it very difficult to work with this SDK.

Hi Carson,

Is this the same version (v_2) that your site points to? The readme in v_2 that your site points to refers to the latest project as ‘~new’ instead of ‘~v_2’. The reason I ask is that I am dealing with the same errors this conversation thread addresses, using the v_2 from your site.

Could you provide a URL here for each, please … (for my sanity)
URL of zoom-sdk-windows-master latest
URL of zoom-c-sharp-wrapper-master latest

Is v_2 the same as ‘new’? I have gotten errors with v_2 referencing ~DOT_NET_~WRAPPER vs ~C_SHARP~_WRAPPER so I cant be sure if I’m using a correct build.

Thanks Carson!

OK I have built both projects, here’s what my issue was in case anyone hits the situation where no matter how they follow the instructions, and include everything in every conceiveable path, it can still not find linked symbols, and what the issue was. Hint C++/C# newbie pilot error.

When I first tried to build the combined solution, and chose (don’t do this) upgrade the tools reference, it caused an update force on windows 10. Then an install of VS 2015, then 17 etc. to handle incremental tools issues,and during all this some reference to Windows dlls version conflict (I’m assuming) caused the underlying issue. Reistallation of VS 2019 and a clean setup on the _V2 project enabled building both the C++ sdk project and the combined demo solution.

Thanks for all your help guys