X-zoom-app-context is empty when accessing app on some devices

For my app’s use-case, I’m saving the value of the x-zoom-app-context header. So when a user initially opens the app, the value gets stored. The issue I’m facing is that on some devices i’m getting the header twice, once it contains the actual value and the second time around it’s empty so the actual value gets overwritten

Another thing to note here is that this issue seems to be device specific. I tried reproducing this issue using the same Zoom account and same app on a different device but it was working fine there

It’d be great if anyone can help troubleshoot this issue and get to the root cause of it

@mubashira.salman On what devices are you seeing this discrepancy? Does this depend on the OS of the device or something else?

The OS of the device on which this issue is occuring is Windows. But I don’t think it’s OS dependent as the other device on which it was working as expected, the OS is Windows as well.

What version of Windows are you using? Likewise, what version of the Zoom Client are you seeing this with?

When you see this issue, have you confirmed the issue by checking the network tab of the debugger?

Windows 10 + Zoom Client version 5.11.1

Are you able to upgrade to 5.12.3 to see if that resolves the issue?

I did upgrade to 5.12.3 but unfortunately that didn’t help with this

Thank you for testing that! As one final check, can you see if this issue is present when using the Basic Sample App? If we can reproduce the issue using that app then I can point our engineering team in the right direction.

Hi, using the basic sample app that you’ve linked and the issue is still there

This ‘undefined’ is creating problems in my app’s case

Thank you for testing that! I tried this on my end using 5.12.3 on Windows 11 but I wasn’t able to see the same issue.

Here’s how I was logging the context header:

and I was only seeing it printed once:

How are you logging the context header?

previously i was logging the encrypted header

const header = req.header(contextHeader);

But I’ll add the log where you have and let you know what happens then as well

I sent you a DM so that we can set up a meeting and take a look at this live.

Hey, I’ve scheduled a meeting with you. Let me know if you’ve received the invite

Thanks for scheduling the meeting! I had to move it due to Zoomtopia but I look forward to getting this resolved.

Hey Max, I’ve left you a message to reschedule that due to a conflict. Please check

I received your message. Thank you!

Hi @MaxM any update on this?

Sorry for the delay on this. I do have a couple of questions that should help out here:

  1. Are you using the same URL for the home and redirect URL?
  2. When you see this issue, how are you refreshing the page? Different methods will follow a different code path.
  3. When you use the getAppContext() function do you see the same issue?

I hope that helps!

  1. No, home and redirect URL are different
  2. Not quite sure what you mean by ‘refresh’ here. When this issue occurs, we usually use the refresh app option using the ‘Refresh App’ option
  3. Using the getAppContext() function I’m able to see the context value