You do not have permission to live stream. (4,924)

Description
I am a regular user of our company’s zoom and I am assigned to live stream in on our private group. I was successful using it for the past months until today. I checked my Zoom settings and streaming is allowed, but I got those error message : You do not have permission to live stream. (4,924)

can you please help me resolve it.

Error
You do not have permission to live stream. (4,924)

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Zoom cloud meeting to live stream on Facebook Group Page

Which Endpoint/s?
Face book group page live

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

6 Likes

I am having the same problem just now , Error 4924, did anyone know what is happening ?

2 Likes

Also experiencing the same issue, just as described by the OP.

I am experiencing the same issue.

Apparently they added in permission checks to accounts. The account used to stream needs to be added as a member of the main zoom account (Under User Settings). I don’t know if this will fix the problem but I used an account that wasn’t associated with the main account and I was getting errors. Once I made the association, it worked. (This was for youtube live)

Not the problem here. We have the user as a member of our main Zoom account to our custom livestream, and it’s still an issue. We’ve got the same issue here.

Hey, I am having the same issues. @jithinjoyson1997 can you please elaborate on what you mean by " The account used to stream needs to be added as a member of the main zoom account (Under User Settings)"

Hey @MMihaylov, @nydreljack, @dawsoneeow95, @communicationsAI, @jithinjoyson1997, @erique.b.mendoza,

For issues with live streaming to Facebook, there can be a few different causes and solutions.

Zoom does not currently support the new Facebook Live Producer feature, so if you see a notification to “try the new Live Producer” feature, please choose Dismiss to continue the live stream with their original streaming service.

Facebook made changes to their streaming service in early 2018 and now prevents some users from live streaming to groups. If you are unable to live stream your webinar to Facebook, you can configure the Facebook Live stream as a custom service as a workaround.

Besides those two limitations, issues with streaming generally occur when trying to start the stream in your web browser. A new live stream can potentially be using older files from the last time you live streamed, so clearing the browser’s cached files often helps. These instructions for Chrome and Firefox show you how to clear the cache.

Note: Clearing the cache will log you out of all websites on that browser, which will require you to log back in to any sites you were previously logged in to.

You can also try using a different browser to live stream. Open a separate browser, log in to Facebook, then copy and paste the link Zoom is currently trying to open in the browser. This should work very similar to clearing the browser cache, if that option is not possible for you.

Setting up the live stream as a custom service may work better than an instant live stream. It takes a bit more time to configure, but can avoid issues, as Facebook is already expecting a live stream.

This should help to resolve the issue. Certainly let me know if you have any further questions or issues.

For issues unrelated to the Zoom API Platform, please reach out to support.zoom.us, they will be able to better assist! :slight_smile:

Thanks,
Tommy

1 Like

The above reply didn’t really help. This issue just started happening within the last day or two. Is this something that Zoom is working on?

1 Like

We are having the same problem - and this prior to a board meeting - This is the second time this year where the Zoom/Facebook integration is not working together :frowning:
Any resolution?
Cleared cache
tried different browsers
using main account

Can someone from Zoom please help us? Thanks!

1 Like

Yep tried all of this too. Still getting the error message.

I´m having the same problem. I cleared cache and im still having the same error: (4924). This happens when im trying to broadcast to You tube. Please, we need some help to resolve this problem, it seems that is a recent issue.

I’m having exactly the same issue. The live stream function worked for the past 6 months, then in the last week I’ve started getting the ‘You do not have permission to live stream (4,924)’ message.

I faced the same issue while Youtube Live streaming. I also tried via custom streaming but got same error.

I just figured out that, if I click “Youtube Live”, Zoom windows app is redirecting me to Zoom login page (which was not before), there if I login with the same user who created the meeting (NOT meeting host, rather meeting creator) then it’s allowing me to stream live on Youtube.

Seems like Zoom has added additional security to live streaming functionality.

Hope this helps to others,

Thanks & Regards,
Bala.

1 Like

Hey @vihangshah.it, @alex.beard, @eugeniobuzon, @bradley.fosler, @gpcsd, @acowan_2020,

Our product and engineering team is looking into this issue. (ZOOM-196887)

I will share updates with this thread.

Thanks,
Tommy

3 Likes

We’re having the same issue and it is preventing us from being able to stream our local government meetings (we are the community TV station in town). This will be a major issue for us if it is a permanent change.

1 Like

An update for this forum. I tested the configuration with a Macbook Air running OS X Catalina, and it works flawlessly for those that are able to use a Mac. So far, our issue is PC based at the moment.

I’m on a Mac book pro running Catalina and I got the same error tonight and was unable to live stream to Facebook.

We’ve had the problem on both Mac and PC.

For us, it works so far if the account who scheduled the meeting is the one to live stream, but it doesn’t work for anyone else even if host permissions are given.

Does anyone have a similar situation where the account to live stream (and given host permissions) is different from the account who scheduled the meeting?

1 Like

Yes, we have a similar situation. The account owner starts the meeting and makes someone else the host, then the new host starts and stops the stream. This worked fine until last week.

2 Likes