Zoom is not presenting meeting over controller

Hi Carson

Even I am also facing the same problem… It is well connected from my end as waiting pop up came but meeting is not at all connected.
Here I am sharing my logs & screenshot of my code have a look and please help me out to get rid of this issue…

Logs:
2020-07-29 10:28:07.348139+0530 Dasmesh[3255:1305755] onMobileRTCAuthReturn 0

2020-07-29 10:28:07.400506+0530 Dasmesh[3255:1305755] Elearn type : C

2020-07-29 10:28:07.400695+0530 Dasmesh[3255:1305755] selected class details :********* pwd:Fhjkffh**

2020-07-29 10:28:07.402096+0530 Dasmesh[3255:1305755] SeverTimeIntVAl :37677, STTime: 37103, EDTime:37703

2020-07-29 10:28:07.402224+0530 Dasmesh[3255:1305755] You are in time

2020-07-29 10:28:07.443230+0530 Dasmesh[3255:1305755] onJoinaMeeting ret:0 {

"kMeetingParam_IsAppShare" = 0;

**“kMeetingParam_MeetingNumber” = *********;

"kMeetingParam_MeetingPassword" = Fhjkffh;

"kMeetingParam_Username" = “KOMAL V”;

}

error was 0

2020-07-29 10:28:08.795599+0530 Dasmesh[3255:1305755] Metal API Validation Enabled

**2020-07-29 10:28:08.926879+0530 Dasmesh[3255:1305755] onJoinMeetingConfirmed MeetingNo: *************

Thanks & Regards,
Khousic.

*This post has been edited to remove any meeting / webinar IDs

Hi All,

Any Update on the above issue.

We are seeing this issue as well. We get MobileRTCMeetingState(rawValue: 1) which is connecting, but the UI never appears and the call never connects. Worked fine previously, we have updated to the latest SDK.

This is the log when I attempt to start a meeting. There are a bunch of errors, you can also see that it does attempt to connect but never actually connects.

2020-08-06 12:17:26.543460-0400 myapp[258:5588] [logging] misuse at line 154005 of [95fbac39ba]

2020-08-06 12:17:26.594849-0400 myapp[258:5588] No old cache folder exist

2020-08-06 12:17:26.595719-0400 myapp[258:5588] [logging-persist] cannot open file at line 42270 of [95fbac39ba]

2020-08-06 12:17:26.595892-0400 myapp[258:5588] [logging-persist] os_unix.c:42270: (0) open(/var/mobile/Containers/Data/Application/30D026EB-DEDD-407F-9A10-B36750D9D744/Documents/data/zoomus.db) - Undefined error: 0

2020-08-06 12:17:26.597230-0400 myapp[258:5588] [logging-persist] cannot open file at line 42270 of [95fbac39ba]

2020-08-06 12:17:26.597402-0400 myapp[258:5588] [logging-persist] os_unix.c:42270: (0) open(/var/mobile/Containers/Data/Application/30D026EB-DEDD-407F-9A10-B36750D9D744/Documents/data/zoomus.tmp.db) - Undefined error: 0

2020-08-06 12:17:26.642368-0400 myapp[258:5588] [logging] table gg_user_profile_enc already exists

2020-08-06 12:17:26.777045-0400 myapp[258:5588] [logging] table zoom_kv already exists

2020-08-06 12:17:26.777416-0400 myapp[258:5588] [logging] table gg_user_profile_enc already exists

2020-08-06 12:17:26.777699-0400 myapp[258:5588] [logging] table zoom_user_account_enc already exists

2020-08-06 12:17:26.823777-0400 myapp[258:5588] [logging] table zoom_client_action already exists

2020-08-06 12:17:26.851157-0400 myapp[258:5588] [logging] table zoom_kv already exists

2020-08-06 12:17:27.065376-0400 myapp[258:5588] [logging] table gg_user_profile already exists

2020-08-06 12:17:32.303471-0400 myapp[258:5588] [strings] ERROR: Waiting… not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

2020-08-06 12:17:32.303949-0400 myapp[258:5588] [strings] ERROR: Waiting… not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

2020-08-06 12:17:32.353459-0400 myapp[258:5588] [strings] ERROR: Waiting… not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

join meeting: Optional(__C.MobileRTCMeetError(rawValue: 0))

On Meeting Change State: MobileRTCMeetingState(rawValue: 1)

2020-08-06 12:17:33.084929-0400 myapp[258:5588] [strings] ERROR: LN_MEET_VIDEO_PREVIEW_95787 not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

2020-08-06 12:17:33.099934-0400 myapp[258:5588] [strings] ERROR: Close not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

2020-08-06 12:17:33.110350-0400 myapp[258:5588] [strings] ERROR: LN_MEET_VIDEO_PREVIEW_DESC_95787 not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

2020-08-06 12:17:33.124360-0400 myapp[258:5588] [strings] ERROR: LN_MEET_VIDEO_PREVIEW_VIDEO_95787 not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

2020-08-06 12:17:33.126463-0400 myapp[258:5588] [strings] ERROR: LN_MEET_VIDEO_PREVIEW_NOVIDEO_95787 not found in table Localizable of bundle CFBundle 0x107e03b00 </var/containers/Bundle/Application/FE94C2B6-A74B-4B39-AE19-D2E872F7090A/myapp.app> (executable, loaded)

I went back to v4.6.21666.0428 and it seems to work. Not sure what the issue is in v5.0.24433.0616

@Carson_Chen
Can you help us?
The problem as you already reported is in the v5.0.24433.0616 version of the iOS sdk

Hi everyone,

Thanks for the reply. Regarding the issue you are facing, We are able to identify an issue for the situation you are mentioning. When the setMobileRTCRootController is not configured and the video preview feature has enabled(It is enabled by default), the join meeting process will struggle at presenting the video preview view. We will fix this in the next release.

As an alternative solution, please try to configure the setMobileRTCRootController (https://zoom.github.io/zoom-sdk-ios/interface_mobile_r_t_c.html#a74d0a3110932a0f9506b05d6e235b3ba ) or call disableShowVideoPreviewWhenJoinMeeting(https://zoom.github.io/zoom-sdk-ios/interface_mobile_r_t_c_meeting_settings.html#a85841243faa0e974b243ab093d53be88 ) to disable the video preview, this will work as expected.

Thanks!

1 Like

Im able to get the meeting started with below code for IOS app, But when i click on leave meeting doesn’t close(whereas minimize meeting works), I’m using iphone 7 with IOS version 13.6, Zoom SDK version is 5.0.24433.0616

        let zoomService = MobileRTC.shared().getMeetingService()
        zoomService?.delegate = self
        let joinParams = MobileRTCMeetingJoinParam()
        joinParams.userName = “name”
        joinParams.meetingNumber = “meetingnum”
        joinParams.password = “pwd”

        if #available(iOS 13.0, *) {
            // 13.0 and above
            MobileRTC.shared().setMobileRTCRootController(self.navigationController)
        } 
        
        if let error = zoomService?.joinMeeting(with: joinParams){
            print("error zoom call:\(error)")
        }

Hi @idcinfo,

Thanks for using Zoom SDK. Please have a try with the solution above and see if that helps.

Thanks!

Can you please copy link here, which one you are referring to, As i said, i am able to open the Zoom meeting window with setMobileRTCRootController change. But not able to close the meeting when i click on Leave Button and also share extension is also not working in IOS 13.6

Please have a try with the solution here, using the disableShowVideoPreviewWhenJoinMeeting:

If the issue persists, please provide an SDK log for further investigation. Thanks!

I added below code along with initially mentioned, Still no changes found, I am able to Join the meeting, But could not leave the meeting and share extension is also not working.

    let settings = MobileRTC.shared().getMeetingSettings()
            settings?.disableShowVideoPreview(whenJoinMeeting: true )

Logs printed , when Joining meeting and When clicked on share. no logs printed when i tried to click on leave button.

MobileRTCAuthError(rawValue: 0)

error was 0

error zoom call:MobileRTCMeetError(rawValue: 0)

MobileRTCMeetingState(rawValue: 1)

MobileRTCMeetingState(rawValue: 2)

2020-08-13 19:18:55.352162+0530 HealthTechSampleApp[2325:1608455] InitAudioUnit use hardware aec = 1

2020-08-13 19:18:55.571871+0530 HealthTechSampleApp[2325:1608455] [IOS].InitAudioUnit g_audioUinits.count = 1

2020-08-13 19:19:22.907438+0530 HealthTechSampleApp[2325:1608455] [Assert] Error in UIKit client: -[UIWindow setScreen:] should not be called if the client adopts UIScene lifecycle. Call -[UIWindow setWindowScene:] instead.

2020-08-13 19:19:22.954288+0530 HealthTechSampleApp[2325:1608455] [LayoutConstraints] Unable to simultaneously satisfy constraints.

Probably at least one of the constraints in the following list is one you don’t want.

Try this:

(1) look at each constraint and try to figure out which you don’t expect;

(2) find the code that added the unwanted constraint or constraints and fix it.

(

"<NSLayoutConstraint:0x281049770 UIView:0x15fff2ee0.width == - 16 (active)>"

)

Will attempt to recover by breaking constraint

<NSLayoutConstraint:0x281049770 UIView:0x15fff2ee0.width == - 16 (active)>