Zoom Meeting SDK crashing on macOS

Zoom Meeting SDK crashes every time when invoking ZoomSDK.shared().initSDK.

Error on console: Assertion failed: (FALSE), function InitPTAppApi, file ZoomSDKModuleClient.cpp, line 161.

I followed this macOS documentation for the SDK setup.
I’ve come across similar issues in the community, but I don’t see a workable solution. surprisingly the sample app that I downloaded from Zoom marketplace is working for me, I tried my best to replicate the same in my app no luck so far. I’d highly appreciate it if anyone can help me with this issue. Thanks in advance.

Zoom Meeting SDK version: v5.14.5.13410
Xcode version: 14.3
Deployment Target: macOS 11.0
macOS version: 13.3.1

SDK setup code in AppDelegate applicationDidFinishLaunching:

let zoomSdk = ZoomSDK.shared()
let initParams = ZoomSDKInitParams()
initParams.enableLog = true
zoomSdk?.initSDK(with: initParams)
zoomSdk?.zoomDomain = "zoom.us"
1 Like

Getting the same error while trying to initialise. Tried bot in Xcode 13 & 14.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.