ZoomSDK for macOS Error on initSDK: Assertion failed: (FALSE)

I’m experiencing crashes every time I’m trying to initSDK on

  • macOS 12.6
  • XCode 14.0.1
  • zoom-sdk-macos-

Code I’m using:

let zoom: ZoomSDK = ZoomSDK.shared();

func  zoomInit(){
    let params = ZoomSDKInitParams();
    params.needCustomizedUI = false;
    params.teamIdentifier = nil;
    zoom.initSDK(with: params);

Output I’m getting:

Assertion failed: (FALSE), function InitPTAppApi, file ZoomSDKModuleClient.cpp, line 165.

Is there something wrong with your initialized params?

I’ve used this snippet from official MacOS Meetings SDK demo app to set params:

   /* NSString *localeIdentifier = [[NSLocale currentLocale] objectForKey:NSLocaleCountryCode];
    if(localeIdentifier && [localeIdentifier.uppercaseString isEqualToString:@"CN"])
        [[ZoomSDK sharedSDK] setAppLocale:ZoomSDKLocale_CN];
        [[ZoomSDK sharedSDK] setAppLocale:ZoomSDKLocale_Def];*/
    ZoomSDKInitParams* params = [[ZoomSDKInitParams alloc] init];
    params.needCustomizedUI = useCustomizedUI;
    params.teamIdentifier = nil;
    [[ZoomSDK sharedSDK] initSDKWithParams:params];
    [ZMSDKCommonHelper sharedInstance].isUseCutomizeUI = useCustomizedUI;
    params = nil;

And also experimented with other params variations, always the same error

same error message, but no solution

you could try version 5.10 or 5.11, if there are any differences

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I encountered the same problem with version
I am now using version and have resolved the issue.
Are there any plans to fix this problem in 5.12?
We would like to use the latest version as soon as possible.