Zoom Meetings SDK 2.5.0 : Webinar always shows "Joining meeting timeout Fail to join the meeting."

Hi,

i am using Zoom Meeting Web Api / JWT credentials to embed Zoom Meetings / WEbinars on a webpage.
Version is 2.5.0

I include this here:

<script src="https://source.zoom.us/2.5.0/lib/vendor/react.min.js"></script>
<script src="https://source.zoom.us/2.5.0/lib/vendor/react-dom.min.js"></script>
<script src="https://source.zoom.us/2.5.0/lib/vendor/redux.min.js"></script>
<script src="https://source.zoom.us/2.5.0/lib/vendor/redux-thunk.min.js"></script>
<script src="https://source.zoom.us/1.8.3/lib/vendor/jquery.min.js"></script>
<script src="https://source.zoom.us/2.5.0/lib/vendor/lodash.min.js"></script>
<script src="https://source.zoom.us/zoom-meeting-2.5.0.min.js"></script>

Signature is generated with JWT Credentials.

This is working with “normal” Zoom Meetings. But not by using webinars. I use Webinar Passcode + Webinar ID but it always shows an error.

  1. errorCode: 1
  2. errorMessage: “Fail to join the meeting.”
  3. method: “join”
  4. result: null
  5. status: false

I have no idea what i can do on top because zoom meetings are working perfect…
I appreciate your help!

Melanie

PS: The Webinar has no registration set

Hi, @Milenoi,

How are you configuring the Join function for Webinars? Can you share a screenshot of how you’ve configured it? You may also want to check out our support documentation for joining webinars.

Dear Donte,

thank you very much for your help.

I reached out the docs for webinars und i changed my join function

ZoomMtg.join({
                            sdkKey: 'MYSDKKEY',
                            signature: 0, // role in SDK Signature needs to be 0
                            meetingNumber: 'myWEBINARNUMBER', // Just for demo here
                            passWord: '',
                            userName: 'myName'
                            userEmail: 'test@test.de', // any email

                            success: function (res) {
                                ZoomMtg.getAttendeeslist({});

                                ZoomMtg.getCurrentUser({
                                    success: function (res) {
                                        console.log('success getCurrentUser', res.result.currentUser);
                                    },
                                });
                            },
                            error: function (res) {
                                console.log(res);
                                console.log('error join');
                            },
                        });

Then i created a new App: SDK and used the SDK Key + Secret Key to generate a signature.
Now i get a different error: signature is invalid. But its much more better then before :wink:
Is my join function correct? I need an emailadress for webinars, but not necessarily for meetings?

And i cannot use JWT App anymore i have to switch to SDK is this also correct?
Thank you very much for the link to the docs. I tried to search webinar in den docs but some links in search-result are 404.

Melanie

PS: i do not know why i get an error in my sdk app: Is this something i should consider?
By clicking on update app nothings happens…
Bildschirmfoto 2022-07-28 um 17.10.34

Can you try to perform an isolated test using our sample meeting signature generation app?

What you want to do is generate the signature and manually enter the value into the join function. Then you can compare how you are generating the signature against the sample app.

The update will not break your SDK App, It just adds OAuth functionality which is optional to use.See our support documentation for more details :

Dear Donte, yes i did exactly what you proposed: i generated a signature with the sample signature to test an single webinar AND meeting. Both work perfect!
So i have to change my signature generate function in my code und hope the best.

Last question: is it now possible to start webinars with the web sdk who require registration?
I remember, this was not possible ?

@Milenoi,

Are you asking if is it possible to start the webinar as a Host or participant?

Get a user’s ZAK token

No i thought there might be problems if webinar requires registration.

@Milenoi,

It is my understanding that it is possible to start the webinar, in your testing, have you seen differently ?

I will try this tomorror!
Another question: my signature code is written in php but is not working for the new requirements here:

Is there maybe a solution how to do this in php in your docs or do you know a github solution that is working? Sorry to ask… (the code was written by a friend who is familiar with php, i am not).

We do not have a sample PHP signature generation method for the SDK app type. However, there is one for JWT that you can reference :

try this php sample for SDK JWT Signature

Jürgen

Dear Jürgen,

it works! I solved it with your provided link! Thank you SO MUCH all of your for your help!!

:heart_eyes: