Zoom Room 5.2+ CLI zcommand invite not working?

Hi folks. I am developing a system that utilizes Zoom Room’s CSAPI CLI to ring a user via JID. Following the documentation here: https://marketplace.zoom.us/docs/guides/zoom-rooms/zoom-rooms-cli/zCommands

I successfully created a Mac app that would issue the zcommand invite via bash and expect script. The workflow worked great on Zoom Room version 5.1.2. Happy with the result, the department ordered a new Mac to run the app. After installation of the newest version 5.2.2, a test did not produce the same results. Manually SSHing into the API and submitting the invite command does not call a user either. Issuing other commands such as starting/ending a meeting does indeed work, but invite simply does nothing on the terminal.

Does anybody have any tips or settings to check?


Edit: I’m seeing that crash logs are being created every time the zcommand invite is issued. The log shows the room’s JID and email, but nothing else.

Hey @tsirrico,

Thanks for reaching out about this—I’m happy to help raise this question with the right people.

As a first step, can I kindly ask if it’s possible to share the zCommand invite you’re using and any relevant logs you have (after installing 5.2.2)? I’d like to share this with one of our ZR CLI engineers so that they can take a closer look at this.


Hi Will,
Thanks for the response. Here is the requested info and a bit more background info as we have continued troubleshooting.

Our initial working test machine was running macOS 10.15.6 and Zoom Room 5.1.2, while the new computer is running 10.15.7 and 5.2.2. Today we tried a fresh OS installation of 10.15.7 and installed the older 5.1.2, but we are still unsuccessful issuing the invite command.

Here is the workflow- start the licensed Zoom Room and ssh into the CLI via port 2244 from another computer, then issue the following command (obfuscated JID, let me know if you want that info privately):
zcommand invite duration: 5 user: myJID

After pressing enter, the CLI goes to the next line but nothing happens . There is no error, and the CLI does not crash. A file gets created in ~/Library/Logs/zoomRooms/crashlog. Here is the content of one such file- 431.log


Are there any other places to look for logs?


  • The JID in the error log corresponds with the JID of the ZR
  • We created a fresh Room via the web portal to rule that out as a variable
  • The original 10.15.6 w/ ZR 5.1.2 machine now exhibits the same behavior
  • All other zcommands are successful.
  • ‘zcommand call invite user: myJID’ does not work either, neither does starting a Pmi meeting and then inviting a user
  • Accepting an incoming call via CLI with ‘zCommand Call Accept callerJID: myJID’ works fine, but that same JID cannot be reached via the invite commands

Thanks a bunch Will. Best,

Edit: This may not be an issue of Mac or Zoom Room version, but rather an addressbook problem. Our organization is fairly large (50,000 Zoom accounts) but it looks like the addressbook only downloads 24,000ish. The last user on the list has a pipe | in the name; I am not sure if that has any bearing on the problem. We were just successful in calling a random user that does appear in the addressbook. The users that we have been trying to call unsuccessfully are not appearing in the book. Any tips to further troubleshoot this?

Hey @tsirrico,

Thanks for taking the time to provide all of these details. I’m working on getting some more insight from our ZR CLI Engineer. I’ll let you know what I find! (ZOOM-212111)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.