Zoom Telehealth Integration


#1

I was following the blog post for ‘Integrating Zoom with an EMR Platform’. I did follow all the steps provided and still get no response. The blog post specifies the URL to be called as https://www.zoom.us/telehealth?org_id=xxxx&data=yyyyy, which is not the normal API call URL. Calling the above URL just returns a full html page that is an ‘Invalid Data’ error page.

I changed this to call "https://api.zoom.us/v2/telehealth’ and passed in the org_id and the encrypted data (Containing the User Type, User ID and Session ID parameters). Calling this now throws a 404 error (Unable to get connection due to The resource dosen’t exists, ex. invalid/non-existent user id).

Am stuck now and not much help I could find on the community yet as well about the telehealth integration and so this reach out.


#2

After playing around it some more, I got a different error when calling the 'https://zoom.us/telehealth?org_id=XXXXXXX&data=cp%2BovjrP7Pnk5GTxSa8vuc4Heg%2Bj4%2BfmO2lFLJSeoeRs5gUpJvAxBmESoJQPNsufgW4548Zc9ctC%0D%0A9n%2FJqkIyqw%3D%3D%0D%0A

 

This time, it shows 'You can add max 1 paid users. (200) '. My current user is already a paid (Pro) user and not sure what this new error now means.

 

–Sri


#3

Hi, Every time you call this API/URL with a new provider e-mail, Zoom will end up creating a new PRO user - this error just means that you don’t have enough unused licenses in your account. 

You might want to pass your current zoom e-mail (the one you are using to host meetings) and see if it works. If not, you need to purchase additional licenses.

Regards

 


#4

Well, to clarify, I have been sending the request with the user id (email id) of the user that has a ‘Pro’ license. It is not sent with a new user as assumed in the reply. I can see the ‘Pro’ status in my user profile as well and also the same is listed in the users when I call the get users api call too. Something is a miss here causing this error of ‘You can add max 1 paid users. (200)’.


#5

Sri, you are correct that if the same user is being used, then a new user should not be created. Can you share the unencrypted values in the “data” parameter and perhaps a screen shot of the Zoom console showing the users?


#6

The unencrypted data values:

usertype=1&userid=s*******i@nuemd.com&sessionid=09949&firstname=S**&lastname=K******i

Here is a screenshot of the users

 


#7

I suspect there might be an issue on the Zoom side recognizing emails as user IDs. In the release coming out soon, a new email parameter will be added to allow specifying an email address.  

In the meantime, you can try freeing up the Pro user license and let a user get created automatically when sending the request. That same user would then be used for all subsequent requests provided you use the same ID. If still have issues, can try not using an email format for the user ID.


#8

Thanks for the tip and I can confirm that it did work. I changed the user type to basic and it started working. Just to play around, I tried switching around the user ids I was sending in the request and it seems to work for all users now. Not sure I understand this behavior any more. For now, I can continue with my dev integration, but something we will have to understand better before going live for sure.

 

Just realized that I posted it as a different user, so reposting as myself.