Zoom Webhook Validation Failure

API Endpoint

We have a webhook set up to link Zoom to Salesforce - it’s been set up and functional for a few years now. The webhook has started to fail in the last few weeks - we believe this is due to the Enhanced Domains changes being enforced in Salesforce.

We’ve tried to update the URL which is set for our webhook to test out a new domain format for our sandbox but we repeatedly get an error regarding URL validation failing but it doesn’t give much in the way of description.

URL Validation Error

How To Reproduce
Steps to reproduce the behavior:
Go to the endpoint on the webhook and try to change the endpoint. We get the failure message without any additional clarification.

@cmcgloin Hope you will be fine

Here is the session → How to enable Zoom WebHooks

Hey @elisa.zoom - any ideas on what could be failing here with the URL validation? I’m getting absolutely nothing back in the error message. I’ve tried many variations but I think the correct one should be: https://exampleCompany.my.salesforce-sites.com/zoom/services/apexrest/zoomWebhookService

Can you let me know if there’s anything we should look for on this or can you point me towards anyone else? Thanks!

Hi @cmcgloin
thanks for reaching out to us!
Are you receiving a challenge request to your endpoint when you manually trigger the validation?

Thanks for getting back to me @elisa.zoom . Let me try and run some logs on the Salesforce side and see what comes across.

It looks like the save to the site address went through and I’m now getting 200 back which is good. However in the logs, it looks like I’m only getting visibility to the meetings which are in the main developers personal room. Is that standard for an unvalidated app perhaps or is there any other reason why the scope of the records would be limited?

Hey @elisa.zoom - apologies for duplicate message. Any ideas why a webhook would be limited to just a certain users events rather than org wide?


Hi @cmcgloin
Sorry for the late reply, I was taking some time off and I am just catching up.
Could you please confirm what app type are you using to receive these events?