ZoomSdk method 'getRunningContext' not working

In our app we’ve been using the zoomSdk method getRunningContext to determine the UI to be shown depending on the context ‘inMeeting’/‘inMainClient’. It had been working fine till I’d last worked on my app i.e. till Friday.

But since today I’ve been facing this issue that whenever I try to use this method in the main-client context, it returns this error:

zoom-apps-js-sdk.0.11.0.js?1674467014:154 Uncaught (in promise) Error: No Permission for this API. [code:80012, reason:require_meeting_role]
    at new ZoomApiError (zoom-apps-js-sdk.0.11.0.js?1674467014:154:32)
    at Object.<anonymous> (zoom-apps-js-sdk.0.11.0.js?1674467014:199:49)
    at ZoomSdk.native2js (zoom-apps-js-sdk.0.11.0.js?1674467014:169:45

But in the meeting context, it works as expected.
I’ve tried updating the sdk to the latest version but that didn’t work either.


hi @mubashira.salman we are able to reproduce the issue and reported it to the team to work on a fix

1 Like

We are also seeing this issue of getRunningContext not working inMeeting for non-hosts.

Will throw our hat in the ring and say that we are also having this issue as of this morning. In our case, it’s failing when making the config API call. We’ve tried a few things to get around it with no luck. We have also not changed any of the permissions for our app in months.

Any ETA on a fix, so we can let our impacted users know?

Just a note that we were able to work around the getRunningContext issue by manually setting the context to “inMeeting” by using the “getUserContext” method to detect a user’s meeting role. Otherwise we fallback to setting the running context to “inMainClient”.

We have created a bug ticket for it and our team is working on it to solve the issue. I will keep you updating regarding this issue. Thanks

1 Like

Correction, the config API is actually working for us, but yes, it is failing on the getRunningContext call as well.

Hello, has this issue been fixed?

@mubashira.salman @shawn.nikkila
getRunningContext works as expected now. Thanks!


Yes, just verified it. Thank you! :raised_hands: