After linking Zoom oAuth, why is the owner account registered but other users are not registered?

We registered oAuth as User Managed app and our development environment is PHP-Web.
I am a beginner in development.
After registering the Zoom oAuth Draft account and developing oAuth authentication, the owner account has been successfully registered and the Token has been received, but other users cannot be registered.
When registering another user, the message “OOPS It may have been deleted or you don’t have permission to view it right now” appears and the registration fails.
Is it not possible to register other users in the Draft account? Can I register other users only after being officially registered on the Marketplace? Is it not possible to register other users during the development and testing phase?
Or is there something wrong with my oAuth setup options?
Waiting for expert’s answer.
Thank you ~

Hi @oncledu
Thanks for reaching out to the Zoom Developer Forum and welcome to our community!
It looks like this could be due to the User managed app. When working with this app type, only the users that created the app will be able to authorize it and use it.
You will need to work with an Admin Level app

Thank you for the reply.
Where do I configure the Admin Level app?
When you say Create an OAuth app, do you mean Account-level app and not User-managed app?
The same error comes out when I set it to Account-level.
I also set all On in ADMIN APP MANAGEMENT > Permissions, but the same error occurs.
Please let us know if there are other settings related to the Admin level app.


<?php require_once 'config.php'; $url = "".CLIENT_ID."&redirect_uri=".REDIRECT_URI; ?>

Login with Zoom

/* ->Move to Zoom screen, Zoom account oAuth authentication */

/* When authenticating on the Zoom screen, it is received as return Url (callback, php), and when authenticating with an account other than the owner’s account, it does not come as a callback and an error */
try {
$client = new GuzzleHttp\Client([‘base_uri’ => ‘’]);

 $response = $client->request('POST', '/oauth/token', [
     "headers" => [
         "Authorization" => "Basic ". base64_encode(CLIENT_ID.':'.CLIENT_SECRET)
     'form_params' => [
         "grant_type" => "authorization_code",
         "code" => $_GET['code'],
         "redirect_uri" => REDIRECT_URI
 $token = json_decode($response->getBody()->getContents(), true);

} catch(Exception $e) {
echo $e->getMessage();

Hi @oncledu
could you please record your screen with the issue you are seeing? I will send you a private message so you can send me the video there.

I’ve sent you a testable URL.
If you need to review the source, we will also send you the source.
Thank you

Hi @oncledu
I have followed up in the Private message.