Audio not working on Safari when joining as attendee

Description
When joining a webinar on Safari as an attendee, you cannot hear the audio. It works as a panelist.

Error
Audio doesn’t work

Which Web Meeting SDK version?
1.9.8

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Join a webinar on Safari as an attendee.
  2. Audio doesn’t work.

Screenshots

Device (please complete the following information):

  • Device: Desktop
  • OS: macOs
  • Browser:Safari
  • Browser Version: 14.1

Additional context
It works if your role is a panelist or if the host gives permissions to talk

1 Like

One of our clients also reported a similar issue with Audio for their students using MAC or Windows OS during the webinar. @tommy can you please provide some feedback on this problem?

It happens when using the Zoom Join from Your Browser option too so not sure if it’s only a WebSDK issue.

@giancarlo1 When you see this happen, do you have Web Isolation enabled or does this happen even with the Sample Web App? I’ll work to reproduce this on my end and get in contact with our engineering team if this seems to be bug.

@elearningevolve What version of the Web SDK are you using? Is this only with Webinars as well? What browsers did you see this with on Mac and Windows?

Thanks,
Max

@MaxM Web isolation is enabled. It does happen even using the Zoom Join from your Browser(not WebSDK) option

The audio works when you are a panelist but it doesn’t work when you are an attendee.

@MaxM Here are the console logs, where you can see there may be an issue. You can see the difference with Chrome.

Chrome:

Safari:

Zoom browser - Safari:

This is a critical issue for us(I can even see, it happens on your platform), is there a way to prioritize it? @tommy @Michael_Purnell

1 Like

Hey @giancarlo1,

Thank you for reaching out to the Zoom Developer Forum. Thank you for clarifying. If you see an issue that happens on the Web Client as well as the Web SDK (or just from the Web Client) then you’ll want to reach out to our Support Team as they’ll be able to assist directly.

Thanks,
Max

@MaxM I couldn’t create a ticket, can you help me with that?

Hey @giancarlo1,

Thank you for letting me know, that likely happened if you submitted a ticket from a Free Account. Do you have an email associated with a paid account that you can use to submit the ticket?

Thanks,
Max

Hey @giancarlo1,

My apologies, I forgot to let you know that I have since reached out to our engineering team in regard to this issue. I’ll let you know when it’s resolved.

(ZOOM-309162)

Thanks,
Max

1 Like

it’s safari limitation before we find another way solve this. you need change safari->performance->websites-> auto-play
enable zoom.us or you domain allow all auto-play

1 Like

Hey @giancarlo1 , @elearningevolve ,

We are working on a fix, but for the workaround like Jack said, you can have your user navigate to their Safari Preferences once they are on your site, and then enable “Allow All Auto-Play” and they will be able to hear webinar audio.

Thanks,
Tommy

Thanks for the update !

1 Like

You are welcome! :slight_smile:

-Tommy

This post was flagged by the community and is temporarily hidden.