Automatically schedule meeting to non-organizational users with ID and Password

Hi, I’m trying to schedule appointments to users that enter their e-mails and phones in my application (nothing to do with Zoom)and schedule a meeting with them, providing an ID and password to meet at the selected day and hour.

I’m just seeing documentation for zoom members and organizational stuff. I’ve visited this topic and a staff member recomends to “create an app en marketplace”, but in Marketplace there are different “apps” to be created: JWT, SDK, Oauth so I don’t know what to do.

I tried JWT in a local sample but thats just for organizational members, and is throwing “User xxx does not exist or doesnt belong to this account”

I’ve also tried cloning the Github application and I’ve successfully joined a meeting (with myself) but I’m not sure how to interact with a “scheduler account” and send that information. I also tried an http post to /meeting and is throwing me that error described before.

Thank you in advance.

Hi @k.chicagualar, to schedule meetings on behalf of someone outside of your account, the user will need to authorize you to do so. This is done using OAuth, which allows you to request an access token to use APIs on their behalf. Check our our OAuth docs, or our OAuth sample app to go through this request flow. With authorization to create meetings for a user, you won’t need a scheduler account.

Let us know if you have any questions.

1 Like

Thank you very much Michael, I’ll definitely try it!

1 Like

Thanks Michael!

Let us know how it goes @k.chicagualar! :slight_smile:


Hi, I’ve been trying to make the sample app work but it’s throwing an error “SyntaxError: Unexpected token u in JSON at position 0”, because the response is “undefined”.

i’ve set and .env file called “credenciales.env” and looks like this:

I’ve also set the Development Redirect URL for OAuth to the same “redirectURL” above, and I’ve whitelisted it.

I’ve been searching around the web and it seems to be a problem with the .env but can’t understand why, it has the same shape as the one described in the Sample Project instructions… not a single space between, I’ve tried with “http” and “https” ngrok redirect and I’m having the same result.

If it matters, my directory is this way:

├── ngrok-stable-windows-amd64/
        ├── ngrok.exe
├── zoom-oauth-sample-app
        ├── .git
        ├── node_modules
        ├── .gitignore
        ├──  credenciales.env
        ├── index.js
        ├── package.json
        ├── package-lock.json

Thank you in advance

Hey @k.chicagualar,

Please try renaming the file to have a dot in front.


Also make sure you are referencing process.credenciales.env and not just process.env