Connection issues Web Meeting SDK

Description
We are using the Zoom Meeting Client View Web SDK in our software. For a few days now we’re encountering very strong connection issues which I will describe in the following:

  • The client successfully joins a meeting, but then after a few seconds loses connection and redirects to the leaveUrl.
  • in some cases we are noticing a very high latency - up to 20 seconds. With this behavior the SDK is almost unusable as it’s not possible to react to what someone in the call said.
    We are using the SDK in a plain HTML file with nothing else but the zoom SDK in it, following the sample code provided in Zoom docs. This HTML file is loaded into our software via iframe.
    The same problems appear in SDK version 2.0.1 and 1.9.0 (other versions have not been tested).
    Is this a known problem? If so, are you able to tell us, if, when and how it will be fixed?

Browser Console Error
Unchecked runtime.lastError: The message port closed before a response was received.

Which Web Meeting SDK version?
2.0.1

Meeting SDK Code Snippets
sample code

To Reproduce(If applicable)
server issue seen in video

Screenshots

Device (please complete the following information):

  • Device: Windows Client
  • OS: Windos 10
  • Browser: Chrome
  • Browser Version 96.0.4664.45
1 Like

Hey @dennis.tietz,

Thank you for reaching out to the Zoom Developer Forum and for reporting this. I’m tracking this issue in another post, please follow up there:

Thanks,
Max