Get meeting participant reports does not returns the registrant_id field

Get meeting participant reports


I’m using the Get meeting participant reports endpoint in order to get participants report on a specific meeting instance(using its uuid).

By the documentation of this endpoint, it looks like when I’m using the query parameter include_fields=registrant_id it should return a parameter named registrant_id for each one of the participants in the meeting.

The problem is, when I call to that endpoint as follows:<instance_uuid>/participants?include_fields=registrant_id

for each participant I get a result with the following format(the data is fake):

            "id": "",
            "user_id": "16779264",
            "name": "Jaiden Ullrich",
            "user_email": "",
            "join_time": "2023-02-05T15:32:40Z",
            "leave_time": "2023-02-05T15:33:21Z",
            "duration": 41,
            "attentiveness_score": "",
            "failover": false,
            "status": "in_meeting",
            "customer_key": ""

the id field is empty, and there is no registrant_id field in the response. That causes a major problem on my end since I rely heavily on the registrant_id for back-end calculations.

Is there a problem with this endpoint? am I using it wrong? how can this problem be solved?

How To Reproduce
Steps to reproduce the behavior:
1. Schedule new meeting with occurrences and registration checked.
2. Register few people to that meeting(let’s say 3).
3. Start the meeting, and enter with all the people that are registered.
4. With that meeting id/instance of that meeting(if using occurrences) send a request to<instance_uuid>/participants?include_fields=registrant_id*
5. You don’t see the registrant_id of the participants in the meeting.


I use a similar endpoint, but for webinars instead of meetings. Registrant id is returned automatically with that. For meetings, I wonder since someone does not typically need to be registered, if you’re not getting registrants because there are no actual registrants. There are only the participants who click the link and show up.

Thank you for answering!
In our case the registration for the meeting is required so every participant must have registrant_id.
On top of that, if we use the list meeting registrants endpoint( we get all of the registrants

Interesting. From that link: " A host or a user with admin permission can require registration for a Zoom meeting. List users that have registered for a meeting." I never knew that.

At this link, and others, Zoom will sometimes say that it works for a meeting OR webinar id. Which is confusing given that there are parallel endpoints for the different services.

What happens if you try submitting the meeting id to the webinar get registrants endpoint? I assume this won’t work, and your app may not even have the scopes to use it.
There are seemingly redundant things that have the same url it seems but are different endpoints, you could try this one in addition to what you’ve been trying:

  • GET /past_meetings/{meetingId}/participants

IIRC I found that the “reports” group of endpoints did not always work as described, and I used the webinars group of endpoints as much as possible.

I thought about the endpoint you mentioned but we want to analyze the participation data that we get and that endpoint does not supply enough data for our needs

I am having the same problem. Zoom has suddenly stopped providing registrant_id in the response. Id serves the same as registrant_id (we have been using this format for a couple of years and never had any issue). I am also getting empty in id.

I am having the same problem. My app used the email to know who attended the meeting, Then ZOOM changed that (without previous notice) and we had a mess chabging everything to ID. Now Id is not available???
I am just using:{uuid}/participants
Come on guys!! We just need to do something as simple as tracking the participants. You can’t change these things without considering the consequences.
Please review this as soon as possible,



Hi @devuso @didaris and @lechuz
Thank you so much for bringing this to our attention.
I am reaching out to internal stake holders about this and I will come back to you with an update shortly.


We are seeing the same problem from our ISV account, the participant report no longer return the registrant_id all a sudden this week, and it’s impacting our whole operation in production.

FYI, we have seen this problem back in March 2021, and Zoom has fixed it back then, but for some reason it is being resurfaced again.

Zoom team / @elisa.zoom , please help fixing this.

1 Like

We are also facing the same issue from our account.
Due to which we are enable to deduct the participant join and leave time for our reports.

This is impacting our reports. Please help fixing this.

1 Like

It seems that Zoom solved this bug. They added that fix to their changelog:

You can close this issue.

1 Like

Thanks for your patience everyone!

Hello Elisa just want to make sure …

  1. Has this issue been solved? If not yet, when will it be resolved (due date)?
  2. Is it possible to obtain the data during this period when this issue occurred even if it is not linked now?

thank you

1 Like

Dear Elisa, do you have any updates yet? Our interfaces from Zoom are depending on this response value.


API returning registrant_id from yesterday afternoon until today morning.
But from today afternoon 1PM IST it is not returning the registrant_id for this API.


Hi @PSDS @Jegan and @teacherz1
The registrant_id issue was solved and you should be able to see it in your response.

I see that the registrant_id issue was indeed solved.
Please notice that the id field though is still empty.

We use the following endpoints and functions.
The URL is {{baseUrl}}/report/meetings//participants?page_size=

The Id field is still empty. Please advise when Zoom will fix the issue.

1 Like

Dear Elisa, the id was solved for two days or so and now is again empty. We a re having serious problems with this. Can you please let us now if you are trying to solve this? Thanks

Hi @lechuz
Are you not able to see the registrant_id?