Getting a SyncRegistrantsBatch error in Salesforce Zoom app

Description
We just upgraded to v 3.14 of the Salesforce Zoom app, which currently does not appear to create zoom webinar records in Salesforce. As a stopgap, we’re leveraging zapier to create the webinar for now. However with the upgrade we get this error on SyncRegistrantsBatch “First error: Before Insert or Upsert list must not have two identically equal elements”

Error
First error: Before Insert or Upsert list must not have two identically equal elements on SyncContactsBatch

Which App?
Zoom App

How To Reproduce (If applicable)
Steps to reproduce the behavior:
Complete any webinar

Hey @zoom33 ,

Happy to help! Can you please provided a screenshot of this error?

Thanks,
Tommy

Hi there apologies for the delayed response, here is the error.

Hey @zoom33,

Thank you for providing more information. Have you confirmed that the list of data sent from Zapier doesn’t contain duplicates?

Thanks,
Max

I don’t see any duplicate records so far, but I am currently testing turning off a Zoom Sync to evaluate what may be occurring.

How can we tell if there is a duplicate record, however. Would this be through a record in SFDC or something of that sort.

Hi again, so here’s what we did.

We turned off the Zapier zap (our backstop for the inability to create webinar records in Salesforce), and created a webinar in Zoom. The Zoom Salesforce integration however does not appear to create the zoom webinar record in Salesforce (hence why we used Zapier as a backstop to create the zoom webinar record).

But as I am checking our debug log it appears there is some activity with Zoom and Salesforce, although no records are being created and no known errors are being invoked. We have all the right settings and have even checked the zoom config settings too. Is there anything we’re missing, or some other steps.

Thanks for sharing more info @zoom33 .

Can you check to see if this thread solves your issue?

Thanks,
Tommy

Unfortunately, this doesn’t solve the matter, as the syncing worked for a while and then stopped. Still doesn’t and it appears this message board doesn’t contain any specific instructions on what to do. Can we perhaps have you look at our setup to troubleshoot, we can grant you support access.

Hey @zoom33 ,

Yes, we can take a look at your setup. Please email developersupport@zoom.us with a link to this thread and we will share the grant support access instructions. :slight_smile:

Thanks,
Tommy