Is "mute_upon_entry" option in personal settings prioritized to meeting API settings?

Using this template helps us debug your issues more effectively :slight_smile:

Our server always creates meeting with the option turned on, but the option in the created meeting is turned on or not depending on the personal meeting settings.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
create meeting endpoint
(POST /users/:userId/meetings)

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Turn " Mute all participants when they join a meeting" option off in the personal settings page. (
  2. Send create meeting request with the option turned on.
  3. Check the response has the option turned off.

Additional context
If the title is right, the option is useless using meeting API.

Hey @cmygray,

Thank you for reaching out to the Zoom Developer Forum. I attempted to reproduce this issue with an internal account but I didn’t see the same behavior. I tested with the Mute all participants when they join a meeting setting enabled and disabled at the account and user level.

In all instances, I saw that the returned meeting object after using the Create a Meeting API had a mute_upon_entry value that matched the request I made.

Are you able to share some more details on how I can reproduce the issue? If you’re able to provide the request body that you’re using that would be helpful. Also, please confirm if you are setting the Mute all participants when they join a meeting option at the user or account level.


1 Like

Thank you for the reply.

I tested some direct request to Zoom API(without our server), and there was no problem setting the mute option through the request body. It is clear now that our server has some deployment issues. Thanks.

Hey @cmygray,

I’m happy to hear that helped! Feel free to reach out if you encounter any further issues or questions as you debug your server/deployment.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.