Is there any way to send video to the ZoomSDKRawDataSender in resolution higher than 640x480?

Description
Currently we are able to send a raw data video via the ZoomSDKRawDataVideoSourceController by setting an external video source.
We successfully get the “onInitialize” delegate call, but there is only one capability in the capability list with 640x480 resolution and the same capability is set as “suggestedCapability”.
When we are trying to send a video frame that is bigger than suggested, SDK seems to trim the input to 640 by 480. In this case additionally we get periodic video artefacts (green strips) on the Zoom side.
When sending a video feed to the native Zoom app in another way (by using our custom virtual webcam driver), we are noticing that native app supports better resolution (at least 720p).
Is there any way to send video to the ZoomSDKRawDataSender in resolution higher than 640x480?

Which macOS Meeting SDK version?
5.9.1.3536

Device (please complete the following information):

  • Device: Apple Mac Mini 2020 M1
  • OS: macOS Monterey 12.2

Hi @mcfly,

Can you please confirm what the return value of isCatcHHDVideoOn is when you are unable to send 720p? And when you use your virtual webcam to successfully send video data, is this using the same SDK instance in the same meeting?

Thanks!

Hi @jon.lieblich ,
isCatchHDVideoOn was set to False. However, setting it True did not change anything.
Webcam driver is completely different flow, it does not use SDK. Our application is sending a video stream to the driver and the driver is used by the native Zoom client on Mac.

Hi @mcfly,

In that case, it isn’t clear what is preventing you from being able to send 720p. Can you please provide the SDK logs so that we can investigate further?

Thanks!

Hi @jon.lieblich ,
Here is a link to the log file: Google Drive: Sign-in

I’ve also noticed a side effect from enabling enableCatchHDVideo - the web camera is becoming active right after this call. Is this an intended behaviour?
If yes, when is the best moment to enable this? Enabling when SDK is authorised seems to be a bad choice because the user may become confused on why the camera is enabled when it should not be in use.

Hi @mcfly,

It does not look like I have access to that Google Drive link. Can you please grant access when you have a chance?

I’ve also noticed a side effect from enabling enableCatchHDVideo - the web camera is becoming active right after this call. Is this an intended behaviour?

This setting works similarly to the video settings window in the Zoom client, wherein you would have a video preview active when you are on that screen in order to access that setting. So yes, this is expected behavior. If you are actually transmitting video to other users in the meeting though, that would probably not be expected behavior. Can you confirm whether or not this is the case?

Thanks!

Hi @jon.lieblich ,
An access has been updated, please check: ZoomHelper.app_0.log - Google Drive

@jon.lieblich , the camera is not used at the moment of the call, but it remains active, even if the meeting is not started.

Hi @mcfly,

Thanks for the logs, we’ll investigate this and let you know once we have any updates.

the camera is not used at the moment of the call, but it remains active, even if the meeting is not started.

Right, so this is due to the design of the video setting window mentioned earlier. I can definitely see why this could be a privacy concern for your end users though, since seeing a camera light turn on unexpectedly could make them think their video is being captured against their wishes. Let us look into whether or not we can change this behavior and get back to you.

Thanks!

Hi @mcfly,

Just a quick update regarding the active camera issue, it looks like this should be resolved in the 5.10.6 release at the end of this month.

Still looking into the HD issue though and will let you know when we find anything.

Thanks!

Hi @jon.lieblich ,
Thank you, waiting on your suggestions regarding HD issue