Join a meeting without launching new activity

Currently, I am using “meetingService.joinMeetingWithParams(this, params, opts);”

Which either launch the default zoom meeting activity or a custom UI by extending “MeetingActivity” in another activity.

is there a way to just join while staying in the same activity (keep it in the foreground) or making the zoom meeting activity a fragment that I can show in the original activity when a meeting is started and hide it afterwards.

@mohammed.aljammali

Please add the key value in the config.xml
key:zm_config_conf_activity value:You activity name which extending MeetingActivity

<string name="zm_config_conf_activity">You activity name which extending MeetingActivity</string>

Hi Fred,
this solution only gives me the option to create my own zoom new Activity. I am looking to stay in the same activity while joining a zoom meeting.

I found the solution
ZoomSDK.getInstance().getMeetingSettingsHelper().setCustomizedMeetingUIEnabled(true)

Hi mohammed.aljammali,

Thanks for the reply. Our SDK offers 2 solutions for the meeting components:

  • Zoom default UI - everything is the same as the official Zoom client, but you will have limited configuration options.
  • Custom UI - Everything is under your control, you need to draw your own UI.

What Fred was suggesting is for the Zoom default UI. However, if you would like to have more controls and more customization like you have mentioned, Custom UI is the right way to go with. Glad you found the solution.

Hope this helps. Thanks!

Hi! I’m encountering the same issue in my project now. Basically the UI I need to display is:

the upper portion of the screen shows the Zoom Meeting UI, the lower portion of the screen shows the UI of my existing Activity.

I’ve read the discussion above and enabled custom UI mode by setCustomizedMeetingUIEnabled(true). I can then toggle the visibility of some buttons / windows, but I still could not find a way to make the entire zoom meeting UI NOT full screen. Please forgive me if I missed some steps. Could you give some suggestions how to make it work? Any help is appreciated!

Thank you!

Hi Guangda,

Thanks for using Zoom SDK. If you would like to use Custom UI, after setting the Custom UI by calling the setCustomizedMeetingUIEnabled, you might want to call isCustomizedMeetingUIEnabled to double check whether the Custom UI is truly enabled. The Custom UI feature is a paid feature so it is not available for all accounts.

If you do not want to purchase Custom UI feature, one of our demo apps shows a way of implementing a similar outcome of what you are mentioning without using Custom UI.

Hope this helps. Thanks!

Hi Carson,

Thanks a lot for your reply! I found the similar implementation from the “example 2”. And I was able to fit the Zoom video view into a window.

I’m encountering a new issue though, when I execute the meetingService.joinMeetingWithParams(this, params);, the MyMeetingActivity (the one that extends the SDK’s MeetingActivity) won’t be opened automatically, user has to click the zoom android notification to enter the MyMeetingActivity. How can I make the MyMeetingActivity running by itself after joinMeetingWithParams is executed?

Besides, the password dialog (the input dialog that allows user to enter their password) doesn’t show up the zoom meeting view is opened.

My meeting params / options are exactly the same as the example 2 demo app, is there anything I missed?

Thanks again!

Hi Guangda,

Thanks for the reply. I have replied to your question in The android SDK "sample" demo app stuck in "preparing meeting" black screen

On the other hand, regarding the following that does not exist in another question:

You could specify your own meeting activity in config.xml like https://github.com/zoom/zoom-sdk-android/blob/master/mobilertc-android-studio/example2/src/main/res/values/config.xml#L4, then extends the MeetingActivity in your MyMeetingActivity. Then you could define your own logic in your MyMeetingActivity(Such as override the back button, etc.)

Hope this helps. Thanks!

Thanks! This solves my problem.

Glad to hear that the problem has resolved. Happy Zooming! :slight_smile: