Join meeting with a password

I am attempting to have the demo application join to a meeting that is setup with a password/passcode and I am having troubles joining. Please advise.

Which version?
Zoom Windows SDK C# Wrapper v5.0.24433.0616

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Start a Zoom meeting: for instance, https://<my_domain><my_meeting_number>?pwd=<my_meeting_password>
  2. Run the C# wrapper demo app
  3. Enter user name, meeting number, and meeting passcode (or password?? Or what else??)
  4. According to the onMeetingStatusChanged callback, the app attempts to join the meeting, but immediately disconnects, then gives a status of ERROR.

Additional context
I can’t get the app to join the meeting. I feel like it has something to do with the password/passcode that I am providing. I say that b/c I am able to join a meeting that has no password/passcode setup for it - meaning, I simply enter my user name and meeting number and it joins successfully. So my guess is that it is related to me doing something wrong with the join params. I have tried it with the password provided in the URL and with the meeting passcode. Neither of those worked.

Here is my code:

JoinParam param = new JoinParam();
param.userType = SDKUserType.SDK_UT_WITHOUT_LOGIN;
JoinParam4WithoutLogin join_api_param = new JoinParam4WithoutLogin();

join_api_param.meetingNumber = // <my_meeting_number> (from Zoom URL)
join_api_param.userName = // <First Last>
join_api_param.psw = // What goes here exactly???  The password in the URL or something else???

param.withoutloginJoin = join_api_param;

SDKError err = CZoomSDKeDotNetWrap.Instance.GetMeetingServiceWrap().Join(param);
if (SDKError.SDKERR_SUCCESS == err)

It seems that this is only a problem when I try it with a meeting that I have created with my corporate Zoom account. If I create the meeting with my personal Zoom account, I am able to access the meeting successfully by entering the meeting passcode.

So I guess it could be a different in security settings? But I would imagine that I should still be able to join my corporate-account zoom meeting since I have the passcode.


1 Like

Hi @bamajap, thanks for the post.

Can you please clarify which error code you are receiving when you are unable to join the meeting?


Appreciate the help!

For reference, here is the signature of my event-handler for the meeting status changes event:
public void onMeetingStatusChanged(MeetingStatus status, int iResult)

When I run the demo app, I enter my info, select the ‘Join’ button, then this is what I see for the status and iResult (in parenthesis) values from the debugger:

    (At this point, Zoom opens and acts like it is about to join the meeting, then closes)

Hey @bamajap,

I believe the issue you are facing has to do with the meetings in your corporate account enforcing log in. Can you try logging into Zoom through the SDK then try the same meeting number and password with the same join parameters? If you see the same behavior there we can investigate further. If this lets you join the meeting it is because that meeting is enforcing log in.


Hi, this has started happening to me this week :scream:

I can join personal meetings, but not corporate ones. I have been joining corporate meetings for 6 months from my app with no issues (JoinMeetingWithoutLogin). The last corporate meeting I could successfully join was on saturday 2021/02/06.

I’m using the Electron SDK (which is based on Windows and Mac SDKs) last version available: v5.4.54802.0124. No changes were made to our codebase, it just suddenly stopped being able to join corporate meetings, we still don’t know why.

@Michael_Condon no configuration change has been made to the corporate account and login enforcing has been always disabled (and still is). My users have the same exact issue in both Mac and Windows platforms (Zoom opens and acts like it is about to join the meeting, then closes). So they can’t join their corporate meetings, but they can successfully join personal meetings.

Could this be caused by some issue within Zoom’s servers?

Thanks for your help, we don’t know what to do.

1 Like

Hey @desko27,

Thanks for using the dev forum!

What happens when you try to join those same meetings without logging in using the Zoom Desktop Client Applications?


Hi @Michael_Condon, I can join those same corporate meetings without logging in using standard Zoom Desktop Client Applications, other people can too.

We are a bit frustrated because the software we made was really really helpful for managing our meetings and we suddenly can’t use it for them :’(

Thanks in advance for any help!!

@Michael_Condon I also checked the following scenarios directly in Electron SDK demo with different meetings:

  • Joining without login
  • Joining with login

So it seems like it doesn’t actually matter if I’m logged in or not. I couldn’t join any corporate meeting by any means through the SDK, but I could successfully join every personal meeting I tried through the SDK.

I have the exact same issue. Everything was working fine with our private custom Zoom app until this very date. Joining Corporate Meetings results in the same event sequence

  3. MEETING_STATUS_FAILED (10) (! I get always 10 here instead of 23 !)

Joining my personal meeting works fine.

We are using C# Wrapper Zoom SDK and a not published app.
Is your app published in zoom marketplace @desko27?

@andrez Thanks for writing, I’m glad to see confirmation about more devs facing this issue, this is driving me crazy.

Is your app published in zoom marketplace @desko27?

No, our app is private as well.

Ok, do you use JWT auth or hardcoded secrets?

I just try to find some things that we both might not have tried. I am using hardcoded secrets (oops).

I use JWT auth in my app. Anyway, trying to join corporate meetings through the official demo for Zoom Electron SDK v5.4.54802.0124 results in the same outcome right now, so I don’t think we can change something in our apps to fix this by ourselves, unfortunately :persevere:

Ok. I have also searched the settings of our corporate account but there are no new settings that may deny join of third party apps.

1 Like

Hi again!

I just found out today that corporations can enforce a requirement for a minimum version of Zoom clients.

Given that, if your corporation sets a minimum required version that is higher than the one available in the SDKs (say, 4.5.6 when the current SDKs version is 5.4.5), then the application will never be able to join until a new SDK version is released.

I’m still not 100% sure but that may be the case in our corporate account, @andrez could that be your case as well?

No, there are no settings related to that in my settings. But there are other settings that our corporate admins defined that I cannot change. But I can see them and there is nothing related to minimum version.

Well, maybe the admins have even more settings that one cannot see as corporate account user.

Where did you find the info about this enforcement of version?

Hi @andrez I cannot verify this, but I also think that the corporate admins can define settings that one cannot see as a corporate account user.

I found out because someone closer to the corporate admins told me in the first place. Then, I remembered helping a user to update the Zoom application (on a tablet) because she received an error telling version was not high enough to join the meeting. So everything made sense.

After all these findings, I’m currently waiting for a new SDK version to be released so my app can join those meetings again.

1 Like

Hey @desko27 and @andrez,

I believe you guys are on to something. Another developer @jeremy.provost is facing the same issue on a separate platform and also believes this is related to the “minimum required version” setting you were mentioning. This seems to be a platform-agnostic SDK issue. I will try to escalate this internally, as this is likely happening to many people.

Stay tuned.


@Michael_Condon is there any expected date for a release of new SDKs so we can surpass the version requirement by updating? My app is unfortunately unusable right now :cry:

Hey @desko27,

I understand this is far from ideal. The engineers are still trying to identify the root cause of this issue. For now, I would suggest disabling the “Require minimum client version” setting entirely. I will update you as soon as I hear from the engineers.