Joining meeting timeout - Signature is invalid

Description
I am using the sample app and I am trying to join a meeting. I am using JWT API key/secret to generate the signature (Basically it is implemented in the sample app, I just inserted my API KEY/SECRET).

Signature: TDN6QmE2eGlRTEN5UmJNTHI4LU5SQS45MTcxMTk0Njc3Ny4xNjExMjQ2NjA0ODE4LjAuR00xR2JTWnljbjNFK2ZVU1ZBc3NYNkQzWTBmK0djZy9YZTV6WHo2SzU2RT0

meeting number: 91711946777

When I am trying to join a scheduled meeting, i get a “Joining meeting timeout” error as described below:

Error
Joining meeting timeout.
Signature is invalid.

Steps to Reproduce

  1. Download sample app from github
  2. npm install
  3. Replace API KEY/SECRET with actual values
  4. npm start
  5. insert meeting number and meeting password
  6. click join

Which version?
Sample app version 1.8.6

Screenshots

Device

  • Device: MacBook Pro
  • OS: BigSur (11.1)
  • Browser: Chrome

Any ideas?

Hey @manolis,

Thank you for reaching out to the Zoom Developer Forum. Looking at the signature provided, it doesn’t seem to match the API Key and Secret in the JWT app you have on your account. Please make sure that you are getting your credentials from the following page:

I also noticed that there isn’t an SDK App created or activated on your account. While you will use the JWT credentials to authenticate, you’ll still want to create an SDK App on your account.

I hope that helps! Let me know if you have any questions.

Thanks,
Max

Hi Max,

Thanks for the quick reply. I’m afraid your answer is not quite clear and in the documentation these details are not specified.

  1. I have a JWT app set up, which allows me to get an API KEY/SECRET.
  2. You are saying this is not enough and that I have to create another app, an SDK app.
  3. I have created an SDK app, but the credentials there are named SDK KEY/SECRET.

I tried both the credentials from the JWT and SDK app, with the same results. I still get the same error.

Signature from when I tried to connect with the SWD Application, SDK credentials: bnhheTk1cXE5OGFXbHlIcmxvcFFnS2tGOTFWT1hEOGRRTmxYLjk2ODUxOTE0NDI5LjE2MTEzMDM3NzA0OTEuMC5Ba1dMQzhsdFFTczJETlRnSjZHVjd0b0tmdE1LMnFkS3FUSXR1MUwyekc4PQ

Signature from when I tried to connect with the JWT Application, API credentials: TDN6QmE2eGlRTEN5UmJNTHI4LU5SQS45Njg1MTkxNDQyOS4xNjExMzAzOTczMjUyLjAuYytLdG1ZNTBkK0d3SHJLbW5ZMk0zd3NidmQwU2xzcVdRME9XQjljSklxZz0

Looking forward for your reply,
Manolis

Hey @manolis,

Thank you for the update. My apologies for being unclear, it can be a bit confusing. You will still use the JWT credentials, but you will want to create the SDK app, as you have done. Looking at the Web SDK signature that uses JWT credentials, it doesn’t look like the API Key matches what I’m seeing in your Dialectica meetings application.

Is that the right app to be checking? Make sure that you’re grabbing the API Key and Secret from there and (as shown in the image in my last post) and following our guide to generating a signature.

Thanks,
Max

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.