JWT App never sends the subscribed event to the custom webhook

At the moment we are building an integration with Zoom where we utilizing JWT App to send any payload to our custom webhook when any meeting or webinar ends and all recording available in cloud. Everything works as expected when we use private zoom account to do the PoC but then when we purchase a licensed account in Zoom and create JWT App from that account. The event which we subscribe in JWT App never fired/triggered even though the setup is the same as per the one we configure in JWT App of my private zoom account.
I also have tried to setup the Webhook only but it results the same. We didn’t get any request sent to the custom webhook.

No subscribed event has been sent to the custom webhook from the JWT App

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT App and Webhook

Which Endpoint/s?

https://marketplace.zoom.us/docs/api-reference/zoom-api/events #/paths/recording.completed/post

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create a meeting from our Licensed account
  2. Start the meeting
  3. Ends the meeting
  4. JWT App supposed to post a request to our custom webhook

Additional context
Our Custom Webhook is available to be accessed from public and it response fine when we create direct request to the webhook endpoint.

Hi @sayhello

Welcome to our community and to the Zoom Developer Forum, I am happy to help here!
There are some steps that might help you to debug your issue:

  1. Send a post request to your Endpoint URL, if you do not receive this event then you will have to check your Endpoint
  2. If you DO RECEIVE the post request, but not the Zoom events, try replacing your endpoint with a test endpoint of your preference (such as webhook.site).
  3. If you receive events and Zoom events in this test endpoint, please check that your Endpoint URL is working properly.

Hope this helps,

Hi @elisa.zoom,

Many thanks for your response.
Based on the steps you propose to debug the issue, I can confirm that even after changing the webhook in the JWT App to webhook.site, the event was not sent at all to the Webhook we set.

I can also confirm that for the custom webhook we have, it can receive all request fine.
We use Zapier webhook as the custom webhook.

Below is the setting we have in JWT App and we set it to subscribe to Meeting Starts, Meeting Ends, Webinar Starts, Webinar Ends and all recording ready events.

I tried to do the recording in cloud and the event still did not send to the webhook.site even though we get the email notification from zoom that the recording is ready.

Do you know whether there is any specific configuration on account level which we need to enable?

Any clue would be really helpful.


Hi @sayhello

Of course, I am happy to help.
Interesting, I do not know why this could be happening. Could you please open up a ticket with support here:

Direct that ticket to me and share the link to this post and I will take it from there.
In that ticket, include the account ID or email associated with the JWT app

Thanks a lot
Elisa :slight_smile:

Hi @elisa.zoom,

Apologies for this late response.
We have created the support ticket here https://support.zoom.us/hc/en-us/requests/14453758 and We have added the account email in the ticket as well.

Many thanks for the help.


1 Like

Thanks a lot! @sayhello
I will follow up from there!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.