Problem with installing private app in marketplace


#1

We have created a marketplace app and for now we need to keep it private.

The App credentials, information, feature and scopes “steps” of the App Marketplace guide are done. We tested the app in our own user and everything works as expected.

In order to smooth out the experience we have signed up with a new user and tried the integration. We faced some issues with the notifications but things seem to be smooth now.

Yet, we receive two callbacks per event per meeting (ie. 2 identical meeting started events , 2 identical meeting ended events etc.)

I suspect that an old version of the application pings our callback URLs twice (we can confirm from our logs that the URLs are indeed pinged twice).

How can we see the installed apps for our account and possibly remove the old ones?
We cannot find our app in https://marketplace.zoom.us/user/installed .

Can you help?


#2

Did you use the “Publishable URL” to share with your users to install the app?

What is your app name please?


#3

@bdeanindy Yes, the publishable URL was used.

The app name is called Acrossio


#4

It appears your app has been configured as an “Account-Level” app (meaning only a Zoom Admin can install the app, and it operates at the Account-Level).

These apps are not represented in the way many developers may expect (at this time).

We show only that the app has been installed on an account, but that does not reflect any individual users which are actually using the app.

Am I correct in my understanding of how the Acrossio app has been configured?


#5

Thanks @bdeanindy . Yet this is an Account level app.
We will turn the app into a user level app and try again.


#6

Cool. Let me know if you have any questions.


#7

@bdeanindy we tried with a new User level app but still it does not show up in the “Installed apps” page. Any ideas?


#8

Ah, so we currently only display apps in the “Installed Apps” list which are published on the Marketplace.
I have created a Jira issue so that ANY app is displayed in this list, what type of app it is, and who owns/maintains that app.

In the meantime, there is no workaround of which I am aware.