SDK 1.7.4, error modal title "Joining meeting timeout." message "The service is temporarily"

Description
When using the SDK 1.7.4, we are getting a modal with the title “Joining meeting timeout.” and the message “The service is temporarily”.

Error
Logs show:

{method: "join", status: false, result: null, errorMessage: "The service is temporarily", errorCode: 403}

Network also shows this coming from /info:

/**/localJsonpCallback({status: false, errorCode: -1, errorMessage: "Unknown error.", result: null});

Which version?
1.7.4

To Reproduce(If applicable)
Join a meeting with Web SDK 1.7.4.

Additional context

This was working fine on 1.7.2.

3 Likes

+1 Same for us as well. This is highly annoying. We are paying for multiple licenses and now tomorrow’s webinars are going to make us look really bad.

We are also having the same issue.

same issue for me - the same code works with one of my clients personal meeting id’s but not another client’s, so it’s not consistent? DM me if you want the meeting id’s of the one that works and one that doesnt

This is the exact behavior we’re seeing. Wasn’t working with my company’s internal meeting IDs, was working with a client’s meeting ID.

@davem @anton.skvortsov @brandon.phillips

Could you DM me the meeting IDs that worked and the ones that didnt work along with your account IDs?

Oh i should probably specify that this is an issue we’re seeing with a webinar type. Same code that worked on 1.7.2 before last Friday. All keys and signatures are the same for 1.7.4, only CDN paths have been updated. There was no other “new” instructions given in https://github.com/zoom/sample-app-web

I have the same problem, with all ids i’ve been created.
This working fine with 1.7.2 version, until past friday

1 Like

same issue here, only a problem for some of our customer’s accounts while others are working after the 1.7.4 upgrade.

This still doesn’t work, even with your sample app project, added my zoom api keys, trying to join a scheduled meeting and we can’t get past this “The service is temporarily” message.

Hi @areyes, @dev5

If you can DM me the meeting IDs that are working and not working also your developer emails from marketplace so that we can continue investigating this issue.

Thanks

I am just getting started w/ this SDK by trying to run the sample app and getting the same message. Just so I understand, for those that have been here before, should I expect a resolution to be posted here?

@frank1,

Yes, we’ll post a resolution as here and throughout the forum as soon as the fix is place.
Developer impacting changes during COVID-19

Update, now I get an invalid password message. This is new.

I traced this new behavior down to passwords with special characters in it like @, something that will be escaped. I made it a simpler password and was able to join with the sample app.

My guess is the code changes on /info endpoint don’t html-unescape the password correctly @Michael_Purnell

1 Like

Hey @stan_b,

Thanks for pointing that out, please use alphanumeric passwords until we fix the issue.

-Tommy

Does anyone know what the sample app is actually supposed to do? Behavior has changed for me. I am no getting the a message saying the request timed out, but the actual httprequest response indicates that the signature is invalid.

Hello All,

As of this morning websdk 1.7.4 seems to be working for us, no more “The service is temporarily”.

Sincerely,

Anton

1 Like

This is working for me this morning - thanks @Michael_Purnell

@AussieInSeattle,

Glad that it’s working. We are working on new versions of the WebSDK to improve the user experience. In the meantime let us know if you need anything else.

Thanks

I certainly hope that new update is not going to go as “well” as this one did… :slight_smile: