Server-To-Server OAuth - Cannot see Admin level template for webinar


I create an app using Server-To-Server OAuth and I’m using the Webinar Rest API.
When I use the API to create a webinar with a template_id in the json, it doesn’t work (or at least not completely). The parameters of the template are not set correctly on the created webinar. After looking on Internet, to understand why the template is not working, I found that we have to use Admin Level Template.

I would like to know why we cannot use the regular template that are available through the API ( /users/{userId}/webinar_templates)? (why they don’t act the same way as in the user interface?) If there’s a way to make it works, I prefer avoid using Admin Level Template.

If we have to use the Admin Level Template, I would like to be able to get them through the API and, even better, to filter only on them as the others cannot be used as template.

The admin level template have been activated on this account and I created an admin level template for my webinars. Unfortunately this webinar template doesn’t appear in the list of webinar template when using the api /users/me/webinar_templates from my App (using Server-to-server Oauth).

The checkbox “enable for Account” on the settings for my admin level template is checked.
When I force to use the admin level template by using its ID in the API call, I receive the following error: {“code”:3003,“message”:“Only the template owner has the permission to use this template for Webinar creation.”}

I don’t know what should I do to be able to use this admin level template from the API?

Thank you for your help.

Hi @formations
Thanks for reaching out to the Zoom Developer forum and welcome to our community! I am happy to help here!
Unfortunately, we do not support the webinar admin template via API.
Currently, this is only supported for meetings.

Allow me some time to do some research to see if this feature is being requested and/or is going to be implemented in the future.


Thanks for the answer. I’m wondering why is there a template_id available on the webinar API if it doesn’t work.
I asked for the Admin Level Template on webinar but you didn’t answer to one of my questions, which was:

“I would like to know why we cannot use the regular template that are available through the API ( /users/{userId}/webinar_templates)?”
“why they don’t act the same way as in the user interface?”


Dear @elisa.zoom ,
Could you provide some more assistance with our issue, please?

As stated above, as much as using Admin-level Templates is not possible with Webinars at the moment, we’d like to know how to set settings correctly using standard-level templates for our Webinars.

For example, the audio settings for our webinars are set correctly on the UI level (webinar can only use computer audio) in our template, but as soon as a webinar is created using the API, this setting isn’t taken into account and falls back to “Computer audio or phone” which is not something we want.

Thanks for your help :slight_smile:

Hi @formations
Thanks for sharing more details with me and I apologize for the late reply.
Let me do some testing on my end using the Non admin level templates and I will try to replicate this behavior.

1 Like

Hey @elisa.zoom ,
Did you have the chance to do some testing about this on your end?
We’re having other webinars in the next weeks and we’d love to be ready by that time :slight_smile:
Thank you!

Hi @formations
I apologize for the late reply here!
After doing some testing with templates, I found that some of the settings that are being passed in the template, for example, Computer audio are not being taken into account, due to the way they are set up in the account settings.
So if you go to your Settings > Audio Type and select the Computer audio settings, then when you use your webinar template, it will respect the audio type.