Server to server oauth role permissions

When assigning developer permissions, I do not have the option to enable server to server oauth permissions mentioned in this document: Create a Server-to-Server OAuth App

1 Like

I’m having the same problem.

Hi @elfinch and @barsh, server-to-server OAuth app permissions should now be able to be granted in your admin user role permission page:

Can you please confirm? Let us know if you have any questions with the new auth option :slight_smile:

The “Server-to-server OAuth app” option is visible now; thank you.

The next obstacle developers might encounter is adding scopes that aren’t visible to you in the dialog box. Our team decided to transfer ownership of the app to the account admin temporarily (so the account admin could add the needed scopes), then transfer ownership back to the developer, who could then enter the justification for each scope and continue filling in the other settings.

Yes the option is now available, thanks for your help.

Given permission from Owner/Admin like shown By @michael.zoom but Still don’t have scope(does not contain scopes: [meeting:write, meeting:read:admin, meeting:read, meeting:write:admin].) to the role user?