Trying to Local Test Meeting SDK app

Preformatted text### Format Your New Topic as Follows:
Meeting SDK Type and Version
Zoom Web SDK 2.10.1

I am trying to create a simple app containing an option to enable and disable caption, and on enabling caption, allow participants to change the language as they would required.

I have downloaded Zoom Web SDK 2.10.1 and now trying to local test it. I added the app using Local test option but I couldn’t see the app when I started the meeting. I have tried this in Basic and in Zoom One Pro account.

I have also tried using the following code to test it on localhost:



which opens up the following screen:

However, when I click on Join button, I get the error: Error Code 3, Joining Meeting Timeout

I have looked into sdkKey but didn’t find any. Some posts say that I need to use the key from the JWT app which I am not so sure about as it would also be deprecated, anyways I did but didn’t work.

Please note that this is my first time working on Zoom-related apps so I am not that much familiar. I have tried to go here and there including your forum but didn’t find any solution to my problem.

Hi @maisum279 ,

you need to create an SDK App type on , and use the Client ID and Client Secret for the above mentioned application.

1 Like


Thank you for the reply.

I managed to resolve it. I had to change apiKey to sdkKey. After that, I had to provide a valid signature.

However, when I try to access the meeting now using localhost:9999, it shows up on the meeting screen for a moment and then it goes blank.

Blank Page

So, I tried to access the meeting directly from my Zoom Desktop Client. There, it shows my app as follows:

App accessing content but not showing up

But, I don’t see my app anywhere, just that it’s accessing the content. Can you please guide me?