/users/email returns "false'


#1

Hi there,

I am always receiving the following response for queries to /users/email:

{
 "existed\_email": false
}

Now I noticed that there already was a post on this: GET /users/email only works for “Work Email” auth?

However the users I enquire about have work emails associated with them (they *also* use Google auth, but definitely have a work email.) 

Is there any reason why they might be returning as false?

Thanks,
Rob


#2

Hi Rob, 

For the emails that you’ve tried, can you check to see if they have an icon like below within the Zoom portal? The icon means this email is a Zoom work email and was created through signup/invitation flow.

 


#3

Hi there @Michael,

I accidentally copy-pasted wrong response code–

The one in question is actually a 404 response with the following:

{
 "code": 1001,
 "message": "User not exist: email"
}

Those users definitely have the envelope icon next to the account.

Note: this is on behalf of a sub-account, not sure if that makes a difference– but all of the other APIs I’ve tried seem to work with the account designation, ie:

**GET** https://api.zoom.us/v2/accounts/:accountId/users/email?email=email@domain.com

Thanks and apologies for the muddle up,

Rob


#4

Hi Rob, 

Do you have an email that you use that is receiving this error so that I can take a look?

Thank


#5

Hi Rob, 

Looks like you’re using the wrong API endpoint, please use the GET /users/email

https://api.zoom.us/v2/users/email?email={email}


#6

Hi Michael,

I tested this API call for sub account users and it indeed returned the result of true.
It isn’t clear from the doco that this is the method to search for sub accounts; all other subaccount calls require the designation of /accounts/accountId/[rest of api]

eg: 

https://api.zoom.us/v2/accounts/:accountId/users 

to list users for a sub-account.

Thanks,

Rob