Wrong message when waiting room is enabled

Description
When participant (non host) tries to join zoom before host (waiting) room, we got wrong message modal “You connection is timeout and you cannot join the meeting…”.
Its was good on zoom web sdk version 1.7 but got broke on 1.8 and still the same on 1.9 too.

Error
You connection is timeout and you cannot join the meeting. Please verify your network connectivity and try again.

Which version?
1.9

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Create meeting with waiting room enabled.
  2. Join meeting non-host (guest).

Screenshots
image

Device (please complete the following information):

  • Device: PC
  • OS: Linux
  • Version: Arch linux rolling…
  • Browser: Chromium, Brave 88

Additional context
Participant does not require to be logged in with zoom account, we are using our internal auth system to do that.

I haven’t tried using zoom authenticated user, perhaps that may be the case?

Hi @ankur.sharma,

Thank you for raising this—I can certainly appreciate how this can be confusing.

We are actively working on improving this error messaging and you can expect to see this reflected in an upcoming release. (CS-2980).

Thanks,
Will