ZAAPI not running on Zoom Startup


#1

I am not able to get the ZAAPI.exe running when I start the Zoom APP.
What would be stopping it from running?


#2

Larry: Post the ZR-CSAPI related questions in the ZR-CSAPI forum:

https://devforum.zoom.us/c/zoom-rooms-control-system-api

Check this:

  • Make sure the on the Web Portal, for the Zoom Room, the ZR-CSAPI is enabled, and SSH is enabled, and a SSH passcode is set.

  • It looks like you are on Windows. Check to see if your virus scanner is preventing ZAAPI.exe from launching; you might need to white-list ZAAPI.exe That should not be a problem when we ship the next version.


#3

Scott
I believe the white list is the problem with one of my PC’s because the exe is running on another one I have setup.

I have checked our Web Portal and made sure that everything is enable after our Zoom Account manager added that function to our account. They are locked in the enabled state. I put in a simple “1234” password.

For the PC running the ZAAPI.exe I can open a putty SSH session on port 2244 and get to the login prompt. I type in the room name from my Web Portal setup an I get back that name, the computer IP address and then asked for the password. I put in the same password I had entered in the Web Portal but I get back Access Denied. I tried changing the password in the Web Portal but I still cannot log in.

What can be causing that?

I am working with Control Concepts to get our AMX control system to work with Zoom in 3 rooms here at Blackstone.

Thank You

Larry V


#4

check to make sure you are using the user name “zoom” for the ssh connection: From Linux / Max, it’s:

ssh -p 2244 zoom@xxxxxxxxxx

-Scott


#5

Scott,

The one PC we had working with the SSH connection has now also stop running the ZAAPI.exe program.

We cannot see what is being blocking the program from running.

Any ideas?

This is on a Dell OptiPlex 7050

Larry V.


#6

Larry: Check two things:

  • The ZR-CSAPI only supports one connection at a time. Double check to make sure that you don’t have multiple SSH connections to the Zoom Room

  • Check to verify that no one has launched a Zoom Room Controller app on the iPad / Android, and tried to connect to the Zoom Room; the ZR-CSAPI does not function if the Zoom Room Controller app is connected to the Zoom Room.


#7

Scott,

We are still having trouble keeping the ZAAPI.exe application running on our Dell PC – 7040 mini.

I have included files our Hardware Tech has captured when the ZAAPI.exe tries to startup.

When the program starts up it says “Error – must specify token”

Here is a copy from the ZAAPI Log that was captured:

[8152:10948:01-02/12:55:14.734:DEBUG:ZAPPILogUtil.cpp(34)] Starting ZAAPI Logger

[8152:10948:01-02/12:55:14.734:DEBUG:ZAPPILogUtil.cpp(34)] Zoom Rooms SDK version is 4.3.293.1128

[8152:10948:01-02/12:55:14.734:DEBUG:ZAPPILogUtil.cpp(34)] SSH enabled

[8152:10948:01-02/12:55:14.734:DEBUG:ZAPPILogUtil.cpp(34)] Error - must specify token

We did this on a Dell Laptop running Windows 10 connected through our public WIFI

We are using: ZoomRooms_ZRCSAPI_Beta14 program files.

This is with no IPad connected to the PC.

Any help to get the API running on our AMX control system is appreciated.

Larry V

(Attachment zaapi_0.zip is missing)


#8

The entry “Error - must specify token” usually means that the SSH passcode has been left blank. Be sure that you have set a non-blank SSH passcode on the Web Portal.


#9

Also, There is a possibility that special characters in the passcode might cause problems; try an SSH passcode with only letters/numbers.


#10

Thank you, We have the ZAAPI.exe running and the AMX control system connected to the Zoom Room PC.

Can that be put someplace in documentation that a password must be placed in the web portal room management page?

A note that the ZAAPI.exe will not run if no password has been saved.

Larry V.