SSH Zoom Room API Putty


#1

Hello, 

I have the Zoom Room API enabled on my account. I have it set up on a windows machine and am trying to remote in via putty. I am using port 4422. I get a response “Connection Refused”. I am unsure how to confirm the API service is running on a windows machine.The ZR-CSAPI process verification documentation is for mac only.  Please Advise. 

This is where i received the information 

https://zoom.github.io/zoom-rooms-csapi/index.html


#2

Nick:

I doubled checked to make sure everything is working for my setup, and I can get it going no problem. Some things to try:

  • Verify that you have installed the beta 11 version of the Windows Zoom Room on the PC, from the beta build download site that is in the welcome email. The installer file name should be:

zoomroom.5.0.42440.0102.44491067.EXE

After you install the beta Zoom Room, make sure you can operate the Zoom Room using the iPad controller, so that’s is fully working.

Then shut down the Zoom Room Controller iPad app, so that it doesn’t interfere with the Zoom Room.

Then you need to exit the zoom Room, and copy over some .dll and .exe files: see the beta documentation instructions under “Installing and Launching”.

Then launch the Task Manager, then re-launch the Zoom Room.

To verify that the Zoom Room is running, you can task-switch (ALT-Tab), and select the Task Manager. In Windows 10, open the drop-down for Zoom Rooms (32 bit), and you should see a few processes. One of the processes will be named:

ZAAPI.exe

Which is the ZR-CSAPI.

  • There is a possibility that your firewall is preventing the ZAAPI.exe app from running; I had to configure Windows Defender to allow the ZAAPI.exe file to run.

  • You should then be able to connect to the Zoom Room via an SSH client like PuTTY, using port 2244, and username zoom, with password zoomus123.

For my PuTTY configuration, the only non-default settings that I have set are:

  • Session: Host Name = Your host name
  • Session: Port = 2244 (not 4422)
  • Session: Connection type: SSH
  • Connection -> Data: Auto-login username = zoom

I can also ssh from my Mac, from the command line, using:

ssh -p 2244 zoom@<hostname>

  • Be aware that with the Windows Beta Zoom Room version, the ZR-CSAPI settings on the Web portal (password, enable/disable) do not have any affect. Those settings only affect the shipping Mac version. The password will always be zoomus123.

  • Make sure nothing else is trying to use the SSH connection. If a Crestron box is already connected to the Zoom Room over SSH, then the Zoom room is not going to allow a second SSH connection, and you will get an error when trying to connect.

  • As a last resort, fire up Wireshark on the PC, to verify that there are SSH packets arriving at the Zoom Room from the machine running the SSH client.


#3

Can confirm with Scott that Windows Defender causes some issues with ZAAPI.exe. However, I did not have to manually configure Windows Defender. Instead a dialog box popped up asking for permission for ZAAPI.exe. Simply allowing it worked for me.

However, if no dialog box pops up asking you for permission then you would have to go to Windows Defender Settings->Firewall & network protection->Allow an app through firewall. There you must add ZAAPI.exe to the allowed apps.