Zoom Phone - Recording & Voice mails download_url returning 404

Hi Guys,

I’m struggling downloading resources from download_url attribute from Zoom Phone Recording and Voice mails endpoints. For some unknown reason I keep getting 404 when trying to download from the url that’s provided by that attribute.

I checked Why zoom returns not found response on downloading audio file from record.completed event but it’s not my case as I’m not using the completed hook and this is Zoom Phone, not Zoom recordings.

I also checked Downloading a Cloud Recording Requires Signin, the zak trick looked promising but sadly it didn’t work.

I tried passing an Authorization header with Bearer <auth_token>, no luck.

I also tried downloading the file from a browser, from curl and from my code getting consistently the same error (404).

I’m trying all of these after the phone recordings and voice mails were created days ago, meaning that the resources should be more than ready at this point.

Here’s the URL format (this is an example, hashes are not matching real data, http formatted because I can only put 2 links in my post): (https)://us01pbx.zoom.us/api/v2/pbx/download/account/cAGcS2DLXXCOZAS4K2UcEQ/file/X-HpKYysDWipJuz9wpo4Sg/msg_c065f86d-ca5f-409b-abfa-399fd3ff0de4.mp3

Side note: I’m using Zoom Recordings API for other stuff in my code and I don’t have issues with download_url attribute for those.

Any help is much appreciated. Thanks!

Hey @jarrieta,

We are looking into this and will get back to you as soon as we can.

Thanks,
Tommy

Hi @jarrieta,

Are you logging in as the owner of the recordings?

Hi @Ojus,

No, I’m logged in as an admin and I’m trying to get the call recordings / voice mails of other users.

Hey @jarrieta,

Is this the error you are seeing?

Browser:

Or JSON response:

{
    "timestamp": 1562790200966,
    "status": 404,
    "error": "Not Found",
    "message": "No message available",
    "path": "/api/v2/pbx/download/account/hCGF-grzTiSD_glUUBgjlA/file/XrIPYbtYRF-lTjY3KLoNUg/msg_8cd46eab-7edc-4e6e-829a-66d6264acd52.mp3"
}

Yes, that’s correct. That’s the error.

Thanks, I am checking with our team to see if this is a bug, or if any special auth headers are required. I will let you know as soon as I hear back.

1 Like

@jarrieta,

Good news and not so good news.

Not so good news: this is a bug, but it will be fixed in our next release.

Good news: there is a work around,

If you delete the last part of the url with the {{file name}}.mp3 it will work.

For example, change this

https://us01pbx.zoom.us/api/v2/pbx/download/account/hCGF-grzTiSD_glUUBgjlA/file/XrIPYbtYRF-lTjY3KLoNUg/msg_8cd46eab-7edc-4e6e-829a-66d6264acd52.mp3

to this

https://us01pbx.zoom.us/api/v2/pbx/download/account/hCGF-grzTiSD_glUUBgjlA/file/XrIPYbtYRF-lTjY3KLoNUg

Thanks for your patience and let me know if this helps!
-Tommy

3 Likes

@tommy this worked!

Thank you!

1 Like

You’re welcome, happy to help!