Zoom Windows SDK Chat - Text input is disabled for some users

Description
Zoom Windows SDK Chat - Text input is disabled for some users.
For some users, chat functionality is not working properly. Users can copy paste, can press back and delete buttons… But user can’t input any other text to chat window, text input is preventing in the chat window.

Kindly assist to get rid of this issue.

Which version?
Zoom SDK DotNet Wrap v1.0.7472.30017

Hi @saniltr,

Thanks for the post and pardon the late response. Could you provide the following information:

  1. What is the SDK version that you are using? (The version v1.0.7472.30017 is not an SDK version)
  2. Are you using default UI or Custom UI?
  3. Is this issue reproducible with our demo app?
  4. What is the device/OS of the users that has this issue?

Thanks!

Hi @Carson_Chen,

We are using the latest Windows SDK version.

Preventing text input is only happening for few users. Don’t know how could you reproduce at your end.
Windows 8/10 users have notified this issue.
Android SDK have no issues right now.

Hope you can reproduce this issue any how from your end. Waiting for the positive reply.

Thanks

Dear @Carson_Chen,

Is there any option in Windows SDK, to forcefully enable Chat for all users…?

Thanks!

Hi @saniltr,

Thanks for the reply. We have tried to reproduce this issue on our end but still no luck. Since there is no other customer reporting this(so that we could find some common factors), it is hard for us to troubleshoot this.

The chat feature should be enabled for all users by default if did you disable the chat feature on your account or using SDK interfaces. And if the chat is disabled, the chat button and UI won’t show up in the meeting UI, it won’t show the UI with text input disabled.

You may have a try with the interface IMeetingChatController.SetParticipantsChatPriviledge(SDKChatPriviledge priviledge) (https://zoom.github.io/zoom-sdk-windows/class_i_meeting_chat_controller.html) to set the chat privilege and see if it helps. Thanks!

Hi @Carson_Chen,

The Chat UI is showing for the users.
The issue is happening randomly for the users. The users are here students.
Using one of our Zoom business account, Zoom LIVE classes are going on. Almost above 100-150 students will join that classroom/meeting at a time. The Chat text preventing issue may happen to few students in that Live meeting.

If a student has chat issue in the morning Zoom Live meeting, that student may not have any chat issue in the afternoon Live meeting.

Gathering some information from the students we can either say that the issue may occur with the following points (not sure):

  1. Since meeting members are above 100, may be the issue occurs
  2. Students with Windows 10 OS, notified the problem.
  3. Different meetings are scheduled at different time with the same Meeting ID (Personal Meeting ID)
  4. Some students have no problem in the morning meeting, but have chat issues in the next meeting (afternoon)
  5. Using almost 7 Meeting ID’s at a time, in which these 7 meetings have more than 100 students.
  6. The 7 Meeting ID’s may or may not have chat issue in the morning session, but may have chat issue in the afternoon meetings. It’s randomly.

But in our Android app, we have no chat issues reported yet.

I will share the whole code for your reference if needed for you to check, whether we are doing anything wrong from our end.

Since it’s affecting our business, hope the problem causing with the chat issue can be dig-out and solved soon. Waiting for your reply as soon as possible.

Thanks!

Hi @saniltr,

Thanks for the reply. Sorry to hear that. We have tried to reproduce this issue with our demo app(on Windows 10)based on the points you have mentioned. but so far we are not able to observe this issue. It seems like it has some randomness.

Could you send this question to developersupport@zoom.us with the following information so that we could further investigate?

  • Could you provide the SDK log from the device that has this issue?
  • Could you provide one of the meeting ID that has this issue? (meeting ID and the approx time)
  • Do you have any video or screenshots of the issue?
  • Could you have a try with the demo app and see if this is reproducible on your end?

Thank you.

Hi @Carson_Chen ,

As you mentioned we are providing some details to investigate the issue regarding chat input.

INDIAN STANDARD TIME
MeetingID - 5456544673
Time : 05.57 am
Date : 09-Dec-2020

Also check the below videos (2Nos.) (Drive Links), so you could check.


Hey @saniltr,

Thank you for providing these. To investigate further. Can you provide the SDK logs in an email to developersupport@zoom.us?

Thanks!
Michael

Hi @Michael_Condon,

How can we get the SDK logs?

Thanks

Hey @saniltr

When initializing the SDK, set enableLogByDefault to be true:

ZOOM_SDK_NAMESPACE::InitParam initParam;
initParam.enableLogByDefault = true;

Once it is set, you can find the log file in the path: %appdata%/zoomsdk/logs/

Thanks!

Hi @Michael_Condon

I have forwarded the SDK logs to the following email developersupport@zoom.us

Kindly check, and assist to clear the issue as soon as possible.

Thanks!
SANIL T R

Hey @saniltr,

We received your logs and are now investigating. Thank you!

Michael

Hi @saniltr,

We never meet such issue before and it is really difficult to reproduce. Here are my questions.

  1. Is there any message box which is covered by the meeting UI to prevents the user input?
  2. Does the end user use some IME? Since many apps may grab focus, would you ask the user who meets the issue to use the mouse to click the chat input area then try to input text again?
  3. Are you using duilib in your app?

Regards,
Wilmer

Hi @Wilmer_Sun,

  1. Since the chat input prevention is happening randomly for students, I think no message box is covering up the meeting UI.
  2. Students tried to click using mouse and keyboard too, but couldn’t input the text.
  3. I didn’t get this Are you using duilib in your app? . Could you please explain.

Thanks,
SANIL T R

Hi @Wilmer_Sun,

As mentioned, I could found DuiLib.dll in my bin (library) folder.

Thanks!
SANIL T R

Hi @Wilmer_Sun,

Kindly check the chat issue, we were waiting for your reply. Still not received any reply yet.

Please give us a solution.

Thanks,
Sanil

Hey @saniltr,

DuiLib is the UI library that is used in the SDK demo application. We have not been able to reproduce this issue, so we are struggling to determine if this is an issue within the SDK or unique to your application. Can you see if you are getting the same issue in a small sample version of your application or in the demo application? Without this, we cannot help troubleshoot effectively.

Thanks!
Michael