Autostarting Meeting through depreciated protocol and options?

Hello,

I’ll start by saying we are not developers, however Zoom Support suggested I write a thread here for others to be able to review and determine if there is a way to do what we’re looking for. For us, it’s a very simple task, and we’re close… But so far.

We have a remote-worker television that runs Zoom and launches a scheduled meeting via 2 potential options:
Using the below string, a meeting joins, auto-starts video - however we get a random meeting ID, even when we specify the correct ID.
start “” “zoommtg://zoom.us/start?confno=[meetingnumber]&zc=0”

Using the below string, we do not get auto-video and audio started, however we do get the correct meeting ID:
start “” “zoommtg://zoom.us/join?confno=[meetingnumber]&zc=0”

All references are from:

Support tells us the majority of the link above is now depreciated and unsupported.

We need a solution that can be easily scripted to start the conference, auto start video and audio and allow for our remote employees to then join the meeting.

Any help would be appreciated. Thank you!

Hey @videowall, happy to help!

Is the meeting number you are supplying for the start url already created/scheduled in the Zoom Web Portal?

zoommtg://zoom.us/start?confno=[meetingnumber]&zc=0

Also please share the full start url with the meeting number and other query params you are using so I can help debug. :slight_smile:

Thanks,
Tommy

Hi @tommy, thanks so much for the response.

The meeting number we’re placing is an auto-scheduled meeting that runs from 7:30am to 5pm. (So to answer your question, yes) The script runs at 7:31, and then we force close everything at 5:01.

We’re not using any other query parameters at this time, we’ve tested embed passcodes, and various other things, but really just trying to get the zc=0 to work, which If I understand correctly should auto start the host’s video and audio… It auto starts our audio successfully, but not the video. We need to go push the “Start video” button for that.

Hope that helps clarify and thank you again.

Hey @videowall, happy to help.

I believe the issue is you are not using the rest of the required query params.

Try adding the following query params:

confno={MeetindID}

zc=0

stype=100

uid={hostUserID}

token={tokenFromThisAPICall}

uname=videowall

Full url:

zoommtg://zoom.us/start?confno={MeetindID}&zc=0&stype=100&uid={hostUserID}&token={tokenFromThisAPICall}&uname=videowall

Thanks,
Tommy

Hey @tommy

Now you’ll need to forgive my inexperience with Zoom and finding information.

Could you please tell me where I would find the {hostUserID} and the {tokenFromThisAPICall}?

Would the ID just be the email address of the account? Not sure where to get the API token, either. I figure uname would be what we want to show up in the meeting, correct?

Thank you for the help.

Hey @videowall, no worries! Apologies for not being more specific :slight_smile:

Follow these steps to get the value for the userID and token parameter:

  1. Create a JWT App here
  2. Copy the JWT Token on the “Credentials” page

image

  1. Use postman to make a GET request to https://api.zoom.us/v2/users . On the Authorization tab in Postman, choose the Bearer Token type, and past your Zoom JWT Token in the input. Then click the blue send button.

  1. Copy the id of the user who you want to setup the start url with.

  2. Use postman to make a GET request to https://api.zoom.us/v2/users/{userId}/token?type=zak replace {userId} with the id of the user who you chose in the previous step.

  1. Build the start url with the User ID and Token.

(Correct, the uname is the name you want to show up in the meeting.)

Let me know if that helps! :slight_smile:

Thanks,
Tommy

Hey there @tommy

Apologies for the delay. First, thank you so much for taking the time to take screenshots and walk me through the process here.

Went through everything, rebuilt the string. Same issue. (If not a bit worse). Using /start or /join, the meeting does join, however audio and video are disabled. We have to physically click the “start video” and “start audio” buttons to get them going.

Thank you again, let me know if you have any other thoughts.

Hey @videowall, you are welcome!

Few things to try:

  1. Are you using a Personal Meeting Number for the start meeting url scheme? If so, try using a generated meeting number instead.

  2. Check your profile and account video settings. Make sure they are set to Host Video on, and Participant Video on.

Screen Shot 2019-12-23 at 10.52.32 AM

  1. Checkout our Zoom Rooms product which does what you are trying to accomplish right out of the box.

Thanks,
Tommy

Hi again @tommy!

  1. The meeting is a “scheduled” meeting, that reoccurs, but it’s scheduled, so the meeting ID should not ever change. We wanted to do it that way so that we didn’t need to “invite” and such for our remote employees. How would you suggest we accomplish the same type of task if we’re not doing the ‘reoccurring meeting’?

  2. Host Video and participants video has been turned on in the settings.

  3. We started looking into Zoom rooms after support gave up in helping us, but unfortunately, the expense outweighs what we’d be able to get out of it. The solution isn’t quite right.

Thank you so much again, really appreciate it.

Hey @videowall,

  1. Good point, even though the meeting is started with a different meeting number than the PMI, can you still join the meeting by setting the PMI in the join url?

  2. Great! If you are using a Zoom Client on your TV, make sure the “video off settings are off”:

  1. No worries! :slight_smile:

Thanks,
Tommy

Hi again, @tommy

I just want to clarify on your #1, we don’t have the “Use Personal Meeting ID (PMI) when scheduling a meeting” turned on in the settings, would like me to turn that on to test your thoughts of using the PMI to join the main conference?

I have confirmed that the 2 settings you screenshotted are not checked.

Thanks so much!

Hey @videowall,

You could try turning on the use personal meeting id and test it out. Let me know what the result is.

Thanks,
Tommy

Hi @tommy

Well, sort of progress, but not really? Not sure.

Using the Personal Meeting, I change the syntax, and use:

start “” “zoommtg://zoom.us/join?&confno={ID}&pwd={string}&zc=0”

Doing this, joins the correct meeting ID, starts AUDIO, but no video.

Using:
start “” “zoommtg://zoom.us/start?&confno={ID}&pwd={string}&zc=0”

Doing this, joins the INCORRECT meeting ID, starts AUDIO & VIDEO.

If only I could get a mix of the two… Please help if you can!

Thank you again.

Hey @videowall,

Can you please send me a video of what is happening?

I am unable to reproduce your issue.

Thanks,
Tommy

Hey @tommy

Difficult to make a movie without removing sensitive information to show you everything. Is there by chance another way we can communicate? I see you are labelled “staff” do you work for Zoom and we can call each other?

Thank you so much, sorry about that.

Hey @videowall,

Yes I do work for Zoom! :slight_smile:

You can private message me the video, or we can schedule a Zoom meeting.

Thanks,
Tommy