Autostarting Meeting through depreciated protocol and options?

Hey @550943718,

Please share more details about your use case so we can assist.

Thanks,
Tommy

Tommy,

I am trying to start a meeting from the command line on a Mac. The command I am using is as follows: open “zoommtg://zoom.us/start?confno=XXXXXXXXXX”

It works well, in principle. As in: it opens up Zoom and starts the meeting.

HOWEVER, it starts a wrong meeting ID. I am using PMI (10 digits) in the command above, because I want to start my personal meeting. However, Zooms opens a meeting with a 11 digit ID that I cannot recognise.

Is there a way to use zoommtg call to open a PMI? I tried adding 0 in front of PMI, but it doesn’t seem to be working.

Any suggestions?

Kind regards,
Marek

Hey @marekkowal,

This is actually the expected flow. When a meeting is created using personal meeting ID, a unique meeting ID is also created.

Basically since you can have infinite meetings with your personal meeting ID, we also assign a unique meetingID to handle in our system.

Here is an example when using the UI scheduling a meeting with personal meeting ID:

The personal meeting ID will still work to join the meeting.

Thanks,
Tommy

Thanks, Tommy. I appreciate your response. I can follow your logic there, but I experienced something unexpected there. Yes, the meeting was created with the unique ID, but then, when my participants tried to join using the PMI url (invite link), they ended somewhere else (presumably in a room with a different ID)!
And so, I did some more tests and found a solution that works as intended. The zoommtg call needs to include “action=join”. This way, I join in the right PMI room, and my participants end up in the same room too.

tl;dr:
open “zoommtg://zoom.us/start?confno=XXXXXXXXXX” - doesn’t work as intended
open “zoommtg://zoom.us/start?action=start&confno=XXXXXXXXXX” - doesn’t work as intended
open “zoommtg://zoom.us/start?action=join&confno=XXXXXXXXXX” - works as intended

And so, I solved it, and posting here, as perhaps the solution above is of value for others too.

Cheers,
Marek

1 Like

Thanks @marekkowal for posting the solution! :slight_smile:

-Tommy