Getting black screen in Zoom websdk 1.8.0 when waiting room enabled

Description
When waiting room is enabled then for the attendees the waiting room just showing as a black screen, in 1.7.8 and 1.7.9 it shows like
Please wait, the meeting host will let you in soon.
User Name
with a white background, but in 1.8.0 it shows just a black screen like it is stuck somewhere.
I tried to debug it found that
image
The above HTML is not rendered on it, as it was rendering on 1.7.8 and 1.7.9.

Which version?
1.8.0

To Reproduce
Steps to reproduce the behavior:

  1. Just login as host to zoom websdk on one browser and make the waiting room enable
  2. Then login as attendee on second browser
  3. Use can see just a black screen appears and on host side it will ask to admit

Hey @sumit.cha20,

Thanks for letting us know. We are investigating this issue.

Can you please also share a screenshot of the issue? (CS-2242)

Thanks,
Tommy

try our 1.8.0 demo https://websdkprod.qooeo.com/ join you meeting, if still have black screen, could you give us a screenshot with chrome devtool
it will show a short time blackscreen downloading wasm files


Hi @JackYang,
Yes I am still not getting the loader. I waited around 10min.

Hey @sumit.cha20,

We are working to improve the UI so there is no black screen.

In the mean time, one way to reduce the download time is to call the preLoadWasm function before starting / joining the meeting:

ZoomMtg.preLoadWasm(); // pre download wasm file to save time.

Thanks,
Tommy

@tommy can you recommend a timeline for this. This seems like a regression and I am assuming you can make a hotfix release for this.

Hey @nitin1,

This will be addressed in the next version, 1.8.1.

-Tommy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Hey @nitin1, @sumit.cha20,

In case you are still seeing this issue, we are releasing a fix in version 1.8.5.

Thanks,
Tommy

1 Like