Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again

@tommy
Unfortunately Tommy, the issue is the same , although you reply me that the signature looks correct , kindly support us , where’s the problem. How we can solve it if it’s from our side
Regards and waiting your reply asap

Any Update regards our issue

Hey @ahmed,

Can you please provide a sample github repo so I can debug the issue locally?

I am unable to reproduce this on my end.

Thanks,
Tommy

add ```

Hey @Real_Intel,

Let us know if you have any questions we can help with!

Best,
Will

I am seeing this issue with v1.8.5 when the meeting has not started. With v1.8.3 I would get a more accurate error alert saying that the meeting has not started yet. With v1.8.5 Im getting this connection error. Then when I start the meeting, and retry sdk implementation, the error goes away and I can join the meeting no problem.

If this connection time out error is being caused by meetings not being started, it would be nice to revert to the old error message which was more accurate.

Hey @kurt2,

Thank you for reaching out to the Zoom Developer Forum. Do you see this same issue when using the latest version of the Web SDK (v1.8.6)? When I test on that version I see a more accurate error message when the meeting hasn’t started.

Thanks,
Max

yes, i am seeing the same issue with Web SDK v1.8.6 and its not giving a good user experience. it should say that “Meeting hasn’t started. Please wait for host to join”

Hey @dilipksah ,

We are aware of this issue and working on a fix in a future version.

Thanks,
Tommy

Currently use version web SDK (1.8.0)
Unfortunately I got a problem is a very strange problem
“Joining meeting timeout.
The signature has expired.
But when you reload the page, maybe many times
it might work
I do not know the reason for that

Hey @ahmed,

The next time you encounter this, can you share your signature with us here, as well as a screenshot of the browser console? This will help us to take a closer look.

Thanks!
Will

Hey Will

I am already using Web SDK sample code for generating a signature

it’s code
var signature = ZoomMtg.generateSignature({
meetingNumber: meetingConfig.mn,
apiKey: API_KEY,
apiSecret: API_SECRET,
role: 1,
// role: meetingConfig.role,
success: function (res) {
console.log(res.result);
meetingConfig.signature = res.result;
meetingConfig.apiKey = API_KEY;
var joinUrl =
testTool.getCurrentDomain() +
“/meeting?” +
testTool.serialize(meetingConfig);
(element).attr(“link”, joinUrl); var temp = (""); (“body”).append($temp);
temp.val((element).attr(“link”)).select();
document.execCommand(“copy”);
$temp.remove();
},
});

screenshot
screenPNG

when reload page many of time might work
screen when its work

Hi @ahmed,

Can you double check your time settings on your server?

Please also ensure that your signature expiration is still valid when you start the meeting.

Thanks,
Will

HI Will
The time on the server works fine
Can I understand why it might work once and again not
From where do I know what the problem is because it is very strange
We are in big trouble because of this point

Hi, I’m getting this error when using the react sample app. It’s using SDK v1.9.0. I’ve followed the setup instructions, with the only change being to rename app.js to App.js because the file was incorrectly named out of the box.

  • I’m using a JWT App type for the key (though there’s nowhere in the setup that asks for the secret…)
  • My developer account is Pro
  • I’ve tried both starting a new meeting (with role == 1) and joining an existing meeting (with role == 0) with the same error both times
  • There is no issue with signature generation - my endpoint is live and I’m able to successfully retrieve signatures with Postman

Any ideas on what the issue is or where to look? Other details are that I’m on OS Catalina 10.15.1 and I’ve tried both Brave Browser 1.18.77 (shields down) and Safari 13.0.3. Thanks.

Hey @keaton ,

Did you add your JWT Secret to your signature generation server? :slight_smile:

If you continue to see issues, please create a new topic and fill out the post template so we have enough info to help.

Thanks,
Tommy

Hey @ahmed ,

You need to generate the signature on the server side in UTC time. Checkout this working example:

Thanks,
Tommy

Hey @tommy I hadn’t before, I’d been using SDK app credentials, but changing to the JWT version didn’t help, I’m getting the same error. I’ve made a new topic here.

Thanks for making a new topic @keaton . I will reply to you there.

Thanks,
Tommy